ar71xx: ap81: define mtd layout via command line
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 16:47:41 +0000 (16:47 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 16:47:41 +0000 (16:47 +0000)
Also use the RKuImage macro becasue the original
firmware starts with the rootfs.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 39378

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.10/614-MIPS-ath79-ap81-remove-mtd-partitions.patch [new file with mode: 0644]

index 64cd854a30f3a0269bb1811644ef9a9726258ef7..801fb4cf434a91212ae175d3721fc8e902951382 100644 (file)
@@ -192,6 +192,7 @@ alfa_mtdlayout_8M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs)
 alfa_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,15936k(firmware),64k(nvram),64k(art)ro
 all0258n_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),6272k(firmware),1536k(failsafe),64k(art)
 all0315n_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,256k(u-boot-env),13568k(firmware),2048k(failsafe),256k(art)ro
 alfa_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,15936k(firmware),64k(nvram),64k(art)ro
 all0258n_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),6272k(firmware),1536k(failsafe),64k(art)
 all0315n_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,256k(u-boot-env),13568k(firmware),2048k(failsafe),256k(art)ro
+ap81_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,5120k(rootfs),2688k(kernel),64k(art)ro,7808k@0x50000(firmware)
 ap96_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs),1728k(kernel),64k(art)ro,7872k@0x40000(firmware)
 ap113_mtd_layout=mtdparts=spi0.0:64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
 ap121_mtdlayout_2M=mtdparts=spi0.0:64k(u-boot)ro,1216k(rootfs),704k(kernel),64k(art)ro,1920k@0x10000(firmware)
 ap96_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs),1728k(kernel),64k(art)ro,7872k@0x40000(firmware)
 ap113_mtd_layout=mtdparts=spi0.0:64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
 ap121_mtdlayout_2M=mtdparts=spi0.0:64k(u-boot)ro,1216k(rootfs),704k(kernel),64k(art)ro,1920k@0x10000(firmware)
@@ -876,7 +877,7 @@ ifeq ($(SUBTARGET),generic)
 $(eval $(call SingleProfile,ALFA,64k,ALFANX,alfa-nx,ALFA-NX,ttyS0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,vmlinux.gz.uImage,pb9x-2.6.31-jffs2))
 $(eval $(call SingleProfile,ALFA,64k,HORNETUB,hornet-ub,HORNET-UB,ttyATH0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,kernel_image,rootfs_image))
 
 $(eval $(call SingleProfile,ALFA,64k,ALFANX,alfa-nx,ALFA-NX,ttyS0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,vmlinux.gz.uImage,pb9x-2.6.31-jffs2))
 $(eval $(call SingleProfile,ALFA,64k,HORNETUB,hornet-ub,HORNET-UB,ttyATH0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,kernel_image,rootfs_image))
 
-$(eval $(call SingleProfile,AthGzip,64k,AP81,ap81,AP81,ttyS0,115200,,1310720,6619136,KRuImage))
+$(eval $(call SingleProfile,AthGzip,64k,AP81,ap81,AP81,ttyS0,115200,$$(ap81_mtdlayout),2752512,5242880,RKuImage))
 $(eval $(call SingleProfile,AthGzip,64k,AP83,ap83,AP83,ttyS0,115200,,1310720,6619136,KRuImage))
 $(eval $(call SingleProfile,AthGzip,64k,AP96,ap96,AP96,ttyS0,115200,$$(ap96_mtdlayout),1769472,6291456,RKuImage))
 
 $(eval $(call SingleProfile,AthGzip,64k,AP83,ap83,AP83,ttyS0,115200,,1310720,6619136,KRuImage))
 $(eval $(call SingleProfile,AthGzip,64k,AP96,ap96,AP96,ttyS0,115200,$$(ap96_mtdlayout),1769472,6291456,RKuImage))
 
diff --git a/target/linux/ar71xx/patches-3.10/614-MIPS-ath79-ap81-remove-mtd-partitions.patch b/target/linux/ar71xx/patches-3.10/614-MIPS-ath79-ap81-remove-mtd-partitions.patch
new file mode 100644 (file)
index 0000000..6d403ab
--- /dev/null
@@ -0,0 +1,49 @@
+--- a/arch/mips/ath79/mach-ap81.c
++++ b/arch/mips/ath79/mach-ap81.c
+@@ -33,37 +33,6 @@
+ #define AP81_CAL_DATA_ADDR    0x1fff1000
+-static struct mtd_partition ap81_partitions[] = {
+-      {
+-              .name           = "u-boot",
+-              .offset         = 0,
+-              .size           = 0x040000,
+-              .mask_flags     = MTD_WRITEABLE,
+-      }, {
+-              .name           = "u-boot-env",
+-              .offset         = 0x040000,
+-              .size           = 0x010000,
+-      }, {
+-              .name           = "rootfs",
+-              .offset         = 0x050000,
+-              .size           = 0x500000,
+-      }, {
+-              .name           = "uImage",
+-              .offset         = 0x550000,
+-              .size           = 0x100000,
+-      }, {
+-              .name           = "ART",
+-              .offset         = 0x650000,
+-              .size           = 0x1b0000,
+-              .mask_flags     = MTD_WRITEABLE,
+-      }
+-};
+-
+-static struct flash_platform_data ap81_flash_data = {
+-      .parts          = ap81_partitions,
+-      .nr_parts       = ARRAY_SIZE(ap81_partitions),
+-};
+-
+ static struct gpio_led ap81_leds_gpio[] __initdata = {
+       {
+               .name           = "ap81:green:status",
+@@ -111,7 +80,7 @@ static void __init ap81_setup(void)
+       ath79_register_gpio_keys_polled(-1, AP81_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(ap81_gpio_keys),
+                                       ap81_gpio_keys);
+-      ath79_register_m25p80(&ap81_flash_data);
++      ath79_register_m25p80(NULL);
+       ath79_register_wmac(cal_data, NULL);
+       ath79_register_usb();