Added hci_usb to kmod-bluetooth. Closes #316
authorFlorian Fainelli <florian@openwrt.org>
Wed, 22 Feb 2006 14:58:45 +0000 (14:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 22 Feb 2006 14:58:45 +0000 (14:58 +0000)
SVN-Revision: 3263

openwrt/target/linux/aruba-2.6/config
openwrt/target/linux/brcm-2.6/config
openwrt/target/linux/generic-2.6/modules.mk
openwrt/target/linux/x86-2.6/config

index afda3fad854d72156480a169fd53b4aca5b8c1b6..f560d7e4b2056d4fff9fdac023339324e5e76616 100644 (file)
@@ -469,7 +469,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y
index 303d8fd4f641bd7908f09174a459b9d57f929cea..2cadc578984f383f4753cc733544f540cbc61cab 100644 (file)
@@ -562,7 +562,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y
index 4e8d2e968904904358c33242c197eda264fa75d7..37d7094c5c259a3434c0b765fb815d781af73100 100644 (file)
@@ -342,6 +342,7 @@ $(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
        $(MODULES_DIR)/kernel/net/bluetooth/sco.ko \
        $(MODULES_DIR)/kernel/net/bluetooth/rfcomm/rfcomm.ko \
        $(MODULES_DIR)/kernel/drivers/bluetooth/hci_uart.ko \
+       $(MODULES_DIR)/kernel/drivers/bluetooth/hci_usb.ko \
 ,CONFIG_BT))
 
 
index 5347e6b7d4e0878ad9226ed23c82758e0d797549..339972b670f225a72a08653a0114d43905346c8b 100644 (file)
@@ -592,7 +592,8 @@ CONFIG_BT_HIDP=m
 #
 # Bluetooth device drivers
 #
-# CONFIG_BT_HCIUSB is not set
+CONFIG_BT_HCIUSB=m
+CONFIG_BT_HCIUSB_SCO=y
 CONFIG_BT_HCIUART=m
 CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_HCIUART_BCSP=y