add vtun package
authorFelix Fietkau <nbd@openwrt.org>
Mon, 30 May 2005 21:13:21 +0000 (21:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 30 May 2005 21:13:21 +0000 (21:13 +0000)
SVN-Revision: 1120

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/vtun/Config.in [new file with mode: 0644]
openwrt/package/vtun/Makefile [new file with mode: 0644]
openwrt/package/vtun/ipkg/vtun.conffiles [new file with mode: 0644]
openwrt/package/vtun/ipkg/vtun.control [new file with mode: 0644]

index 0e8dbd3d60a50fefc6de4674d59d3f2f6a72492c..14472d88af8a42806ecb9891f3df3451fa48b7b0 100644 (file)
@@ -76,6 +76,7 @@ source "package/tor/Config.in"
 source "package/ttcp/Config.in"
 source "package/ulogd/Config.in"
 source "package/vsftpd/Config.in"
+source "package/vtun/Config.in"
 source "package/wireless-tools/Config.in"
 source "package/wol/Config.in"
 source "package/wpa_supplicant/Config.in"
index c3432bdeb9ef546470d232442d4e5ec0b98ae1a8..d445745261a4b8b7735e151c7fae5583e3413055 100644 (file)
@@ -100,6 +100,7 @@ package-$(BR2_PACKAGE_TTCP) += ttcp
 package-$(BR2_PACKAGE_UCLIBCXX) += uclibc++
 package-$(BR2_PACKAGE_ULOGD) += ulogd
 package-$(BR2_PACKAGE_USBUTILS) += usbutils
+package-$(BR2_PACKAGE_VTUN) += vtun
 package-$(BR2_PACKAGE_VSFTPD) += vsftpd
 package-$(BR2_PACKAGE_WIRELESS_TOOLS) += wireless-tools
 package-$(BR2_PACKAGE_WOL) += wol
@@ -142,6 +143,7 @@ siproxd-compile: libosip2-compile
 sipsak-compile: openssl-compile
 tcpdump-compile: libpcap-compile
 tinc-compile: zlib-compile openssl-compile lzo-compile
+vtun-compile: zlib-compile openssl-compile lzo-compile
 tor-compile: libevent-compile openssl-compile zlib-compile
 wpa_supplicant-compile: openssl-compile
 
diff --git a/openwrt/package/vtun/Config.in b/openwrt/package/vtun/Config.in
new file mode 100644 (file)
index 0000000..666492e
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_VTUN
+       tristate "vtun"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_ZLIB
+       select BR2_PACKAGE_LZO
+       select BR2_PACKAGE_OPENSSL
+       help
+         A VPN tunneling daemon
+         
+         http://vtun.sourceforge.net
diff --git a/openwrt/package/vtun/Makefile b/openwrt/package/vtun/Makefile
new file mode 100644 (file)
index 0000000..49daaa3
--- /dev/null
@@ -0,0 +1,61 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := vtun
+PKG_VERSION := 2.6
+PKG_RELEASE := 1
+PKG_MD5SUM := 309534fd03c5d13a19c43916f61f4bbf
+
+PKG_SOURCE_URL := @SF/vtun
+PKG_SOURCE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+PKG_CAT := zcat
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VTUN,vtun,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR) ; \
+       $(TARGET_CONFIGURE_OPTS) \
+       CFLAGS="$(TARGET_CFLAGS) \
+       -I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+       ./configure \
+       --target=$(GNU_TARGET_NAME) \
+       --host=$(GNU_TARGET_NAME) \
+       --build=$(GNU_HOST_NAME) \
+       --prefix=/usr \
+       --exec-prefix=/usr \
+       --bindir=/usr/bin \
+       --sbindir=/usr/sbin \
+       --libexecdir=/usr/lib \
+       --datadir=/usr/share \
+       --infodir=/usr/share/info \
+       --mandir=/usr/share/man \
+       --localstatedir=/var \
+       --sysconfdir=/etc \
+       --with-kernel=$(LINUX_DIR) \
+       --with-zlib=$(STAGING_DIR)/usr/ \
+       --with-lzo-headers=$(STAGING_DIR)/usr/include \
+       --with-lzo-libs=$(STAGING_DIR)/usr/lib \
+       $(DISABLE_NLS) )
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+       CC=$(TARGET_CC) \
+       CFLAGS="$(TARGET_CFLAGS) \
+       -I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="-L$(STAGING_DIR)/usr/lib -lssl -lz -llzo -lcrypto" \
+       vtund
+       touch $@
+
+$(IPKG_VTUN):
+       mkdir -p $(IDIR_VTUN)/usr/sbin
+       cp $(PKG_BUILD_DIR)/vtund $(IDIR_VTUN)/usr/sbin/
+       $(STRIP) $(IDIR_VTUN)/usr/sbin/*
+       mkdir -p $(IDIR_VTUN)/etc
+       cp $(PKG_BUILD_DIR)/vtund.conf $(IDIR_VTUN)/etc
+       $(IPKG_BUILD) $(IDIR_VTUN) $(PACKAGE_DIR)
diff --git a/openwrt/package/vtun/ipkg/vtun.conffiles b/openwrt/package/vtun/ipkg/vtun.conffiles
new file mode 100644 (file)
index 0000000..1195041
--- /dev/null
@@ -0,0 +1 @@
+/etc/vtund.conf
diff --git a/openwrt/package/vtun/ipkg/vtun.control b/openwrt/package/vtun/ipkg/vtun.control
new file mode 100644 (file)
index 0000000..1d7ad92
--- /dev/null
@@ -0,0 +1,8 @@
+Package: vtun
+Priority: optional
+Section: net
+Architecture: mipsel
+Maintainer: marcel@slowthinkers.net
+Source: buildroot internal
+Description: A VPN tunnel daemon
+Depends: openssl, liblzo, zlib, kmod-tun