cleaned up XOrg lib/common.mk
authorJohn Crispin <john@openwrt.org>
Fri, 21 Sep 2007 17:23:38 +0000 (17:23 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 21 Sep 2007 17:23:38 +0000 (17:23 +0000)
SVN-Revision: 8924

XOrg/lib/common.mk

index 898e01697498317020a8b6114948136a4d6aebed..0ce35cc1b07b9e01dd75a9846a5134dd612bae93 100644 (file)
@@ -47,15 +47,18 @@ define Build/Configure
        )
 endef
 
        )
 endef
 
-define libXaw-X11R7.1/install
-       rm -f $(1)/usr/lib/libXaw.so.*
-       cd $(1)/usr/lib; ln -s libXaw7.so.7.0.0 libXaw.so.7; ln -s libXaw6.so.6.0.1 libXaw.so.6
-endef
-
-define Package/${PKG_NAME}/install
+define Package/$(PKG_NAME)/install/Default
        $(INSTALL_DIR) $(1)/usr/lib
        find $(PKG_INSTALL_DIR)/usr/lib/ -name lib*so* | $(XARGS) -i -t cp -P {} $(1)/usr/lib 
        $(INSTALL_DIR) $(1)/usr/lib
        find $(PKG_INSTALL_DIR)/usr/lib/ -name lib*so* | $(XARGS) -i -t cp -P {} $(1)/usr/lib 
-       $(call $(PKG_NAME)/install,$(1))
+endef
+
+define Package/$(PKG_NAME)/install
+       $(call Package/$(PKG_NAME)/install/Default,$(1))
+endef
+
+define Package/libXaw-X11R7.1/install
+       $(call Package/$(PKG_NAME)/install/Default,$(1))
+       cd $(1)/usr/lib; ln -s libXaw7.so.7.0.0 libXaw.so.7; ln -s libXaw6.so.6.0.1 libXaw.so.6
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev