python: fix compile error
authorFelix Fietkau <nbd@openwrt.org>
Thu, 19 Aug 2010 15:57:48 +0000 (15:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 19 Aug 2010 15:57:48 +0000 (15:57 +0000)
SVN-Revision: 22730

lang/python/files/python-package.mk

index efc2df8ecd1d6e35b64cae7f6a8227316480a982..f1bbf010ff203151736f7843b784ef96ff1b5f1a 100644 (file)
@@ -20,7 +20,7 @@ define PyPackage
   $(call shexport,PyPackage/$(1)/filespec)
 
   define Package/$(1)/install
   $(call shexport,PyPackage/$(1)/filespec)
 
   define Package/$(1)/install
-       @getvar $$(call shvar,PyPackage/$(1)/filespec) | ( \
+       @$(SH_FUNC) getvar $$(call shvar,PyPackage/$(1)/filespec) | ( \
                IFS='|'; \
                while read fop fspec fperm; do \
                  if [ "$$$$$$$$fop" = "+" ]; then \
                IFS='|'; \
                while read fop fspec fperm; do \
                  if [ "$$$$$$$$fop" = "+" ]; then \