[package] e2fsprogs: fix status reaping with fsck piped to logger, based on patch...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Apr 2012 15:18:17 +0000 (15:18 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Apr 2012 15:18:17 +0000 (15:18 +0000)
SVN-Revision: 31377

package/e2fsprogs/Makefile
package/e2fsprogs/files/e2fsck.sh

index 9e0e9d9c9a4be771a4ab58430dfdc854fa4255ab..79ab92c737f0932e55c35c87d95c8cd84dea7458 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=e2fsprogs
 PKG_VERSION:=1.42
 PKG_MD5SUM:=a3c4ffd7352310ab5e9412965d575610
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
index 3b34239ce774a570347e7efc786cc69f4abf6cd7..22031edb676876b2b777f2a69d6e76447621da95 100644 (file)
@@ -1,12 +1,15 @@
 #!/bin/sh
 # Copyright 2010 Vertical Communications
+# Copyright 2012 OpenWrt.org
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 fsck_e2fsck() {
+       set -o pipefail
        e2fsck -p "$device" 2>&1 | logger -t "fstab: e2fsck ($device)"
        local status="$?"
+       set +o pipefail
        case "$status" in
                0|1) ;; #success
                2) reboot;;