tweak Build/Compile/PyMod: add CPPFLAGS, allow caller to override any of the default...
authorNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 08:44:08 +0000 (08:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 08:44:08 +0000 (08:44 +0000)
SVN-Revision: 8590

include/package.mk

index 074c7aded18aea6471e196c0093acc025444ed4d..0c8886c784c2132bccea921ce7af605e50008244 100644 (file)
@@ -126,12 +126,14 @@ define Build/Compile
 endef
 
 define Build/Compile/PyMod
- cd $(PKG_BUILD_DIR); \
- $(1) \
- CFLAGS='-I$(STAGING_DIR)/usr/include' \
- LDFLAGS='$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib' \
- $(STAGING_DIR)/usr/bin/hostpython ./setup.py $(2) \
- --prefix=$(PKG_INSTALL_DIR)/usr
+       ( cd $(PKG_BUILD_DIR); \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               $(1) \
+               $(STAGING_DIR)/usr/bin/hostpython ./setup.py $(2) \
+                       --prefix="$(PKG_INSTALL_DIR)/usr" \
+       )
 endef
 
 $(PACKAGE_DIR):