ar71xx: move USB host device support into a separate file
authorGabor Juhos <juhosg@openwrt.org>
Sat, 26 Dec 2009 14:19:13 +0000 (14:19 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 26 Dec 2009 14:19:13 +0000 (14:19 +0000)
SVN-Revision: 18940

21 files changed:
target/linux/ar71xx/config-2.6.30
target/linux/ar71xx/config-2.6.31
target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/dev-usb.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/dev-usb.h [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/devices.c
target/linux/ar71xx/files/arch/mips/ar71xx/devices.h
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-825-b1.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w04nu.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb44.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-rb-4xx.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr1043nd.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ubnt.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wndr3700.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wp543.c
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wrt160nl.c

index b01fb42a568d344883eac184fee859646803a479..16c44c2f21b46a50c2d56c627533a82a63ae3e5c 100644 (file)
@@ -10,6 +10,7 @@ CONFIG_AR71XX_DEV_GPIO_BUTTONS=y
 CONFIG_AR71XX_DEV_LEDS_GPIO=y
 CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_DEV_PB42_PCI=y
 CONFIG_AR71XX_DEV_LEDS_GPIO=y
 CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_DEV_PB42_PCI=y
+CONFIG_AR71XX_DEV_USB=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
index afcb93a693d893189effebfc12a76dae580d15da..be330c7900d5ab10f6e74ac4fd9128971aed29b1 100644 (file)
@@ -12,6 +12,7 @@ CONFIG_AR71XX_DEV_GPIO_BUTTONS=y
 CONFIG_AR71XX_DEV_LEDS_GPIO=y
 CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_DEV_PB42_PCI=y
 CONFIG_AR71XX_DEV_LEDS_GPIO=y
 CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_DEV_PB42_PCI=y
+CONFIG_AR71XX_DEV_USB=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
index d3915718214b563aee0ca08a4f02f15110d58f54..d9db5e8595aff56f368cf17113db03d9f9d4a8e1 100644 (file)
@@ -12,6 +12,7 @@ CONFIG_AR71XX_DEV_GPIO_BUTTONS=y
 CONFIG_AR71XX_DEV_LEDS_GPIO=y
 CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_DEV_PB42_PCI=y
 CONFIG_AR71XX_DEV_LEDS_GPIO=y
 CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_DEV_PB42_PCI=y
+CONFIG_AR71XX_DEV_USB=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
index fe9b7a70d815bd0ca7a808053eb133ba0b62918e..9445c1757c750583f6a73cd6facfbddfacedcca4 100644 (file)
@@ -8,6 +8,7 @@ config AR71XX_MACH_AP81
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_AP83
        default y
 
 config AR71XX_MACH_AP83
@@ -15,6 +16,7 @@ config AR71XX_MACH_AP83
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_DIR_615_C1
        default y
 
 config AR71XX_MACH_DIR_615_C1
@@ -31,6 +33,7 @@ config AR71XX_MACH_DIR_825_B1
        select AR71XX_DEV_AP94_PCI if PCI
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_AP94_PCI if PCI
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_PB42
        default y
 
 config AR71XX_MACH_PB42
@@ -45,6 +48,7 @@ config AR71XX_MACH_PB44
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_PB42_PCI if PCI
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_PB42_PCI if PCI
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_AW_NR580
        default y
 
 config AR71XX_MACH_AW_NR580
@@ -66,6 +70,7 @@ config AR71XX_MACH_WP543
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_PB42_PCI if PCI
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_PB42_PCI if PCI
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_WRT160NL
        default y
 
 config AR71XX_MACH_WRT160NL
@@ -74,6 +79,7 @@ config AR71XX_MACH_WRT160NL
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_WRT400N
        default y
 
 config AR71XX_MACH_WRT400N
@@ -87,6 +93,7 @@ config AR71XX_MACH_RB_4XX
        bool "MikroTik RouterBOARD 4xx series support"
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        bool "MikroTik RouterBOARD 4xx series support"
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_WNDR3700
        default y
 
 config AR71XX_MACH_WNDR3700
@@ -95,6 +102,7 @@ config AR71XX_MACH_WNDR3700
        select AR71XX_DEV_AP94_PCI if PCI
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_AP94_PCI if PCI
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_WNR2000
        default y
 
 config AR71XX_MACH_WNR2000
@@ -111,6 +119,7 @@ config AR71XX_MACH_MZK_W04NU
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_MZK_W300NH
        default y
 
 config AR71XX_MACH_MZK_W300NH
@@ -151,6 +160,7 @@ config AR71XX_MACH_TL_WR1043ND
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_AR913X_WMAC
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
        default y
 
 config AR71XX_MACH_TEW_632BRP
        default y
 
 config AR71XX_MACH_TEW_632BRP
@@ -168,6 +178,7 @@ config AR71XX_MACH_UBNT
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_PB42_PCI if PCI
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_PB42_PCI if PCI
+       select AR71XX_DEV_USB
        default y
 
 endmenu
        default y
 
 endmenu
@@ -193,4 +204,7 @@ config AR71XX_DEV_LEDS_GPIO
 config AR71XX_DEV_PB42_PCI
        def_bool n
 
 config AR71XX_DEV_PB42_PCI
        def_bool n
 
+config AR71XX_DEV_USB
+       def_bool n
+
 endif
 endif
index 962af4bb2eecc3dfb7c0f2c86030898c0b224307..9b5c4ddfb485c21ce16c5253c2ca0261dff5aaa4 100644 (file)
@@ -20,6 +20,7 @@ obj-$(CONFIG_AR71XX_DEV_GPIO_BUTTONS) += dev-gpio-buttons.o
 obj-$(CONFIG_AR71XX_DEV_LEDS_GPIO)     += dev-leds-gpio.o
 obj-$(CONFIG_AR71XX_DEV_M25P80)                += dev-m25p80.o
 obj-$(CONFIG_AR71XX_DEV_PB42_PCI)      += dev-pb42-pci.o
 obj-$(CONFIG_AR71XX_DEV_LEDS_GPIO)     += dev-leds-gpio.o
 obj-$(CONFIG_AR71XX_DEV_M25P80)                += dev-m25p80.o
 obj-$(CONFIG_AR71XX_DEV_PB42_PCI)      += dev-pb42-pci.o
+obj-$(CONFIG_AR71XX_DEV_USB)           += dev-usb.o
 
 obj-$(CONFIG_AR71XX_MACH_AP81)         += mach-ap81.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 
 obj-$(CONFIG_AR71XX_MACH_AP81)         += mach-ap81.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-usb.c b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-usb.c
new file mode 100644 (file)
index 0000000..514ab3d
--- /dev/null
@@ -0,0 +1,173 @@
+/*
+ *  Atheros AR71xx USB host device support
+ *
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  Parts of this file are based on Atheros' 2.6.15 BSP
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/delay.h>
+#include <linux/dma-mapping.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/platform.h>
+
+#include "dev-usb.h"
+
+/*
+ * OHCI (USB full speed host controller)
+ */
+static struct resource ar71xx_ohci_resources[] = {
+       [0] = {
+               .start  = AR71XX_OHCI_BASE,
+               .end    = AR71XX_OHCI_BASE + AR71XX_OHCI_SIZE - 1,
+               .flags  = IORESOURCE_MEM,
+       },
+       [1] = {
+               .start  = AR71XX_MISC_IRQ_OHCI,
+               .end    = AR71XX_MISC_IRQ_OHCI,
+               .flags  = IORESOURCE_IRQ,
+       },
+};
+
+static struct resource ar7240_ohci_resources[] = {
+       [0] = {
+               .start  = AR7240_OHCI_BASE,
+               .end    = AR7240_OHCI_BASE + AR7240_OHCI_SIZE - 1,
+               .flags  = IORESOURCE_MEM,
+       },
+       [1] = {
+               .start  = AR71XX_CPU_IRQ_USB,
+               .end    = AR71XX_CPU_IRQ_USB,
+               .flags  = IORESOURCE_IRQ,
+       },
+};
+
+static u64 ar71xx_ohci_dmamask = DMA_BIT_MASK(32);
+static struct platform_device ar71xx_ohci_device = {
+       .name           = "ar71xx-ohci",
+       .id             = -1,
+       .resource       = ar71xx_ohci_resources,
+       .num_resources  = ARRAY_SIZE(ar71xx_ohci_resources),
+       .dev = {
+               .dma_mask               = &ar71xx_ohci_dmamask,
+               .coherent_dma_mask      = DMA_BIT_MASK(32),
+       },
+};
+
+/*
+ * EHCI (USB full speed host controller)
+ */
+static struct resource ar71xx_ehci_resources[] = {
+       [0] = {
+               .start  = AR71XX_EHCI_BASE,
+               .end    = AR71XX_EHCI_BASE + AR71XX_EHCI_SIZE - 1,
+               .flags  = IORESOURCE_MEM,
+       },
+       [1] = {
+               .start  = AR71XX_CPU_IRQ_USB,
+               .end    = AR71XX_CPU_IRQ_USB,
+               .flags  = IORESOURCE_IRQ,
+       },
+};
+
+static u64 ar71xx_ehci_dmamask = DMA_BIT_MASK(32);
+static struct ar71xx_ehci_platform_data ar71xx_ehci_data;
+
+static struct platform_device ar71xx_ehci_device = {
+       .name           = "ar71xx-ehci",
+       .id             = -1,
+       .resource       = ar71xx_ehci_resources,
+       .num_resources  = ARRAY_SIZE(ar71xx_ehci_resources),
+       .dev = {
+               .dma_mask               = &ar71xx_ehci_dmamask,
+               .coherent_dma_mask      = DMA_BIT_MASK(32),
+               .platform_data          = &ar71xx_ehci_data,
+       },
+};
+
+#define AR71XX_USB_RESET_MASK \
+       (RESET_MODULE_USB_HOST | RESET_MODULE_USB_PHY \
+       | RESET_MODULE_USB_OHCI_DLL)
+
+#define AR7240_USB_RESET_MASK \
+       (RESET_MODULE_USB_HOST | RESET_MODULE_USB_OHCI_DLL_7240)
+
+static void __init ar71xx_usb_setup(void)
+{
+       ar71xx_device_stop(AR71XX_USB_RESET_MASK);
+       mdelay(1000);
+       ar71xx_device_start(AR71XX_USB_RESET_MASK);
+
+       /* Turning on the Buff and Desc swap bits */
+       ar71xx_usb_ctrl_wr(USB_CTRL_REG_CONFIG, 0xf0000);
+
+       /* WAR for HW bug. Here it adjusts the duration between two SOFS */
+       ar71xx_usb_ctrl_wr(USB_CTRL_REG_FLADJ, 0x20c00);
+
+       mdelay(900);
+
+       platform_device_register(&ar71xx_ohci_device);
+       platform_device_register(&ar71xx_ehci_device);
+}
+
+static void __init ar7240_usb_setup(void)
+{
+       ar71xx_device_stop(AR7240_USB_RESET_MASK);
+       mdelay(1000);
+       ar71xx_device_start(AR7240_USB_RESET_MASK);
+
+       /* WAR for HW bug. Here it adjusts the duration between two SOFS */
+       ar71xx_usb_ctrl_wr(USB_CTRL_REG_FLADJ, 0x3);
+
+       ar71xx_ohci_device.resource = ar7240_ohci_resources;
+       ar71xx_ohci_device.num_resources = ARRAY_SIZE(ar7240_ohci_resources);
+
+       platform_device_register(&ar71xx_ohci_device);
+}
+
+static void __init ar91xx_usb_setup(void)
+{
+       ar71xx_device_stop(RESET_MODULE_USBSUS_OVERRIDE);
+       mdelay(10);
+
+       ar71xx_device_start(RESET_MODULE_USB_HOST);
+       mdelay(10);
+
+       ar71xx_device_start(RESET_MODULE_USB_PHY);
+       mdelay(10);
+
+       ar71xx_ehci_data.is_ar91xx = 1;
+       platform_device_register(&ar71xx_ehci_device);
+}
+
+void __init ar71xx_add_device_usb(void)
+{
+       switch (ar71xx_soc) {
+       case AR71XX_SOC_AR7240:
+               ar7240_usb_setup();
+               break;
+
+       case AR71XX_SOC_AR7130:
+       case AR71XX_SOC_AR7141:
+       case AR71XX_SOC_AR7161:
+               ar71xx_usb_setup();
+               break;
+
+       case AR71XX_SOC_AR9130:
+       case AR71XX_SOC_AR9132:
+               ar91xx_usb_setup();
+               break;
+
+       default:
+               BUG();
+       }
+}
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/dev-usb.h b/target/linux/ar71xx/files/arch/mips/ar71xx/dev-usb.h
new file mode 100644 (file)
index 0000000..aa49f53
--- /dev/null
@@ -0,0 +1,17 @@
+/*
+ *  Atheros AR71xx USB host device support
+ *
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#ifndef _AR71XX_DEV_USB_H
+#define _AR71XX_DEV_USB_H
+
+void ar71xx_add_device_usb(void) __init;
+
+#endif /* _AR71XX_DEV_USB_H */
index 5c29f8097cc890115c1561c6b49852216b83202e..6261b26cfd9965de20616cee7b4eaec4f9e5bba7 100644 (file)
@@ -14,7 +14,6 @@
 #include <linux/kernel.h>
 #include <linux/init.h>
 #include <linux/delay.h>
 #include <linux/kernel.h>
 #include <linux/init.h>
 #include <linux/delay.h>
-#include <linux/dma-mapping.h>
 #include <linux/etherdevice.h>
 #include <linux/platform_device.h>
 #include <linux/serial_8250.h>
 #include <linux/etherdevice.h>
 #include <linux/platform_device.h>
 #include <linux/serial_8250.h>
 
 static u8 ar71xx_mac_base[ETH_ALEN] __initdata;
 
 
 static u8 ar71xx_mac_base[ETH_ALEN] __initdata;
 
-/*
- * OHCI (USB full speed host controller)
- */
-static struct resource ar71xx_ohci_resources[] = {
-       [0] = {
-               .start  = AR71XX_OHCI_BASE,
-               .end    = AR71XX_OHCI_BASE + AR71XX_OHCI_SIZE - 1,
-               .flags  = IORESOURCE_MEM,
-       },
-       [1] = {
-               .start  = AR71XX_MISC_IRQ_OHCI,
-               .end    = AR71XX_MISC_IRQ_OHCI,
-               .flags  = IORESOURCE_IRQ,
-       },
-};
-
-static struct resource ar7240_ohci_resources[] = {
-       [0] = {
-               .start  = AR7240_OHCI_BASE,
-               .end    = AR7240_OHCI_BASE + AR7240_OHCI_SIZE - 1,
-               .flags  = IORESOURCE_MEM,
-       },
-       [1] = {
-               .start  = AR71XX_CPU_IRQ_USB,
-               .end    = AR71XX_CPU_IRQ_USB,
-               .flags  = IORESOURCE_IRQ,
-       },
-};
-
-static u64 ar71xx_ohci_dmamask = DMA_BIT_MASK(32);
-static struct platform_device ar71xx_ohci_device = {
-       .name           = "ar71xx-ohci",
-       .id             = -1,
-       .resource       = ar71xx_ohci_resources,
-       .num_resources  = ARRAY_SIZE(ar71xx_ohci_resources),
-       .dev = {
-               .dma_mask               = &ar71xx_ohci_dmamask,
-               .coherent_dma_mask      = DMA_BIT_MASK(32),
-       },
-};
-
-/*
- * EHCI (USB full speed host controller)
- */
-static struct resource ar71xx_ehci_resources[] = {
-       [0] = {
-               .start  = AR71XX_EHCI_BASE,
-               .end    = AR71XX_EHCI_BASE + AR71XX_EHCI_SIZE - 1,
-               .flags  = IORESOURCE_MEM,
-       },
-       [1] = {
-               .start  = AR71XX_CPU_IRQ_USB,
-               .end    = AR71XX_CPU_IRQ_USB,
-               .flags  = IORESOURCE_IRQ,
-       },
-};
-
-
-static u64 ar71xx_ehci_dmamask = DMA_BIT_MASK(32);
-static struct ar71xx_ehci_platform_data ar71xx_ehci_data;
-
-static struct platform_device ar71xx_ehci_device = {
-       .name           = "ar71xx-ehci",
-       .id             = -1,
-       .resource       = ar71xx_ehci_resources,
-       .num_resources  = ARRAY_SIZE(ar71xx_ehci_resources),
-       .dev = {
-               .dma_mask               = &ar71xx_ehci_dmamask,
-               .coherent_dma_mask      = DMA_BIT_MASK(32),
-               .platform_data          = &ar71xx_ehci_data,
-       },
-};
-
-#define AR71XX_USB_RESET_MASK \
-       (RESET_MODULE_USB_HOST | RESET_MODULE_USB_PHY \
-       | RESET_MODULE_USB_OHCI_DLL)
-
-#define AR7240_USB_RESET_MASK \
-       (RESET_MODULE_USB_HOST | RESET_MODULE_USB_OHCI_DLL_7240)
-
-static void __init ar71xx_usb_setup(void)
-{
-       ar71xx_device_stop(AR71XX_USB_RESET_MASK);
-       mdelay(1000);
-       ar71xx_device_start(AR71XX_USB_RESET_MASK);
-
-       /* Turning on the Buff and Desc swap bits */
-       ar71xx_usb_ctrl_wr(USB_CTRL_REG_CONFIG, 0xf0000);
-
-       /* WAR for HW bug. Here it adjusts the duration between two SOFS */
-       ar71xx_usb_ctrl_wr(USB_CTRL_REG_FLADJ, 0x20c00);
-
-       mdelay(900);
-}
-
-static void __init ar7240_usb_setup(void)
-{
-       ar71xx_ohci_device.resource = ar7240_ohci_resources;
-
-       ar71xx_device_stop(AR7240_USB_RESET_MASK);
-       mdelay(1000);
-       ar71xx_device_start(AR7240_USB_RESET_MASK);
-
-       /* WAR for HW bug. Here it adjusts the duration between two SOFS */
-       ar71xx_usb_ctrl_wr(USB_CTRL_REG_FLADJ, 0x3);
-}
-
-static void __init ar91xx_usb_setup(void)
-{
-       ar71xx_device_stop(RESET_MODULE_USBSUS_OVERRIDE);
-       mdelay(10);
-
-       ar71xx_device_start(RESET_MODULE_USB_HOST);
-       mdelay(10);
-
-       ar71xx_device_start(RESET_MODULE_USB_PHY);
-       mdelay(10);
-}
-
-void __init ar71xx_add_device_usb(void)
-{
-       switch (ar71xx_soc) {
-       case AR71XX_SOC_AR7240:
-               ar7240_usb_setup();
-               platform_device_register(&ar71xx_ohci_device);
-               break;
-
-       case AR71XX_SOC_AR7130:
-       case AR71XX_SOC_AR7141:
-       case AR71XX_SOC_AR7161:
-               ar71xx_usb_setup();
-               platform_device_register(&ar71xx_ohci_device);
-               platform_device_register(&ar71xx_ehci_device);
-               break;
-
-       case AR71XX_SOC_AR9130:
-       case AR71XX_SOC_AR9132:
-               ar91xx_usb_setup();
-               ar71xx_ehci_data.is_ar91xx = 1;
-               platform_device_register(&ar71xx_ehci_device);
-               break;
-
-       default:
-               BUG();
-       }
-}
-
 static struct resource ar71xx_uart_resources[] = {
        {
                .start  = AR71XX_UART_BASE,
 static struct resource ar71xx_uart_resources[] = {
        {
                .start  = AR71XX_UART_BASE,
index c15f22985f81c07aaa2901d0957a9c36faf9c524..d4dfdcc0dd40d7f037236cac1723d802642a774e 100644 (file)
@@ -38,7 +38,6 @@ void ar71xx_add_device_eth(unsigned int id) __init;
 
 void ar71xx_add_device_mdio(u32 phy_mask) __init;
 
 
 void ar71xx_add_device_mdio(u32 phy_mask) __init;
 
-void ar71xx_add_device_usb(void) __init;
 void ar71xx_add_device_uart(void) __init;
 
 void ar71xx_add_device_wdt(void) __init;
 void ar71xx_add_device_uart(void) __init;
 
 void ar71xx_add_device_wdt(void) __init;
index 05917ba6cb7707136f62a60710d9c097232dcfe3..24d0022fbdbc0e99e4c7c9d2509068b7a5a05764 100644 (file)
@@ -20,6 +20,7 @@
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define AP81_GPIO_LED_STATUS   1
 #define AP81_GPIO_LED_AOSS     3
 
 #define AP81_GPIO_LED_STATUS   1
 #define AP81_GPIO_LED_AOSS     3
index 93072a36015c1fef51eb146ebefdfe86b84d8084..fb5d0533c3c648c0c6342471dc10d3e061c1cdaf 100644 (file)
@@ -25,6 +25,7 @@
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define AP83_GPIO_LED_WLAN     6
 #define AP83_GPIO_LED_POWER    14
 
 #define AP83_GPIO_LED_WLAN     6
 #define AP83_GPIO_LED_POWER    14
index 338110deabb746865ddc636a4360592c92640fdb..47a2c01564326879c976abb2a1f263550d7d1ca2 100644 (file)
@@ -24,6 +24,7 @@
 #include "dev-ap94-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-ap94-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define DIR825B1_GPIO_LED_BLUE_USB             0
 #define DIR825B1_GPIO_LED_ORANGE_POWER         1
 
 #define DIR825B1_GPIO_LED_BLUE_USB             0
 #define DIR825B1_GPIO_LED_ORANGE_POWER         1
index 184e75237be6ef2646ea2ff405889ba23189fe93..6ebfe38dedb27e1adf078aa0d5da0b38b29adbbe 100644 (file)
@@ -19,6 +19,7 @@
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-m25p80.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-m25p80.h"
+#include "dev-usb.h"
 
 #define MZK_W04NU_GPIO_LED_USB         0
 #define MZK_W04NU_GPIO_LED_STATUS      1
 
 #define MZK_W04NU_GPIO_LED_USB         0
 #define MZK_W04NU_GPIO_LED_STATUS      1
index eee6e09110bdacf5300458c3e2ae2209957d6202..10cdf5d2fa09f0715c1a3656747d981451b02125 100644 (file)
@@ -16,6 +16,7 @@
 #include "dev-m25p80.h"
 #include "dev-gpio-buttons.h"
 #include "dev-pb42-pci.h"
 #include "dev-m25p80.h"
 #include "dev-gpio-buttons.h"
 #include "dev-pb42-pci.h"
+#include "dev-usb.h"
 
 #define PB42_BUTTONS_POLL_INTERVAL     20
 
 
 #define PB42_BUTTONS_POLL_INTERVAL     20
 
index 011c05f275e95bccad585cf8f4873f75889fd101..34d264cc053d741035dcede963a81c1bf3700761 100644 (file)
@@ -26,6 +26,7 @@
 #include "dev-pb42-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-pb42-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define PB44_PCF8757_VSC7395_CS        0
 #define PB44_PCF8757_STEREO_CS 1
 
 #define PB44_PCF8757_VSC7395_CS        0
 #define PB44_PCF8757_STEREO_CS 1
index 164ddcc26c98e114b5db735ab36677d9225ee5d9..8f89c43743f891ed5ef40486e966ef25118d1cd0 100644 (file)
@@ -23,6 +23,7 @@
 #include "devices.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "devices.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define RB4XX_GPIO_USER_LED    4
 #define RB4XX_GPIO_RESET_SWITCH        7
 
 #define RB4XX_GPIO_USER_LED    4
 #define RB4XX_GPIO_RESET_SWITCH        7
index 0ab5f2799561713a134ca84349dc988d7496c7d3..baaa2a9bdc628ec65d98955f83aeb80ae4c04712 100644 (file)
@@ -19,6 +19,7 @@
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define TL_WR1043ND_GPIO_LED_USB        1
 #define TL_WR1043ND_GPIO_LED_SYSTEM     2
 
 #define TL_WR1043ND_GPIO_LED_USB        1
 #define TL_WR1043ND_GPIO_LED_SYSTEM     2
index 53b99bdb00d294238f3cb3154dd2129ab11bb63c..478b919c6c07ee4f4265b726d3c38ba53b314d53 100644 (file)
@@ -19,6 +19,7 @@
 #include "dev-gpio-buttons.h"
 #include "dev-pb42-pci.h"
 #include "dev-leds-gpio.h"
 #include "dev-gpio-buttons.h"
 #include "dev-pb42-pci.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define UBNT_RS_GPIO_LED_RF    2
 #define UBNT_RS_GPIO_SW4       8
 
 #define UBNT_RS_GPIO_LED_RF    2
 #define UBNT_RS_GPIO_SW4       8
index befeeda0d6a5a2dea03ce65726cefb24189f4c6c..7cf8e315d170a3cf35fc209b98e5d01ea535b987 100644 (file)
@@ -23,6 +23,7 @@
 #include "dev-ap94-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-ap94-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define WNDR3700_GPIO_LED_WPS_ORANGE   0
 #define WNDR3700_GPIO_LED_POWER_ORANGE 1
 
 #define WNDR3700_GPIO_LED_WPS_ORANGE   0
 #define WNDR3700_GPIO_LED_POWER_ORANGE 1
index cf21632f7e0a22f228000697d61d69fec61f4004..850b0108e38c812897d227e4ad203404d8fc699b 100644 (file)
@@ -20,6 +20,7 @@
 #include "dev-pb42-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-pb42-pci.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define WP543_GPIO_SW6         2
 #define WP543_GPIO_LED_1       3
 
 #define WP543_GPIO_SW6         2
 #define WP543_GPIO_LED_1       3
index bdb3bb61844c847d37d4f070476397884debd5ec..bf3f3c297244be48754bd33eba14e013e4fa0d88 100644 (file)
@@ -19,6 +19,7 @@
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
 #include "dev-ar913x-wmac.h"
 #include "dev-gpio-buttons.h"
 #include "dev-leds-gpio.h"
+#include "dev-usb.h"
 
 #define WRT160NL_GPIO_LED_POWER                14
 #define WRT160NL_GPIO_LED_WPS_AMBER    9
 
 #define WRT160NL_GPIO_LED_POWER                14
 #define WRT160NL_GPIO_LED_WPS_AMBER    9