[package] update netatalk to 2.1.3 (#7864)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 11 Sep 2010 18:38:27 +0000 (18:38 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 11 Sep 2010 18:38:27 +0000 (18:38 +0000)
SVN-Revision: 23010

net/netatalk/Makefile
net/netatalk/patches/001-cross_compile.patch [deleted file]

index 05a8078a10df6073b4eb6ad9517c7b62426ecc5d..7e64db827234434e29255f71a4a5c44aa8b8140a 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netatalk
-PKG_VERSION:=2.0.5
-PKG_RELEASE:=4
+PKG_VERSION:=2.1.3
+PKG_RELEASE:=1
 PKG_SOURCE:=netatalk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/netatalk/
-PKG_MD5SUM:=f35cd7a4ce26c780de380cd2bcae5ce6
 PKG_BUILD_PARALLEL:=1
+PKG_MD5SUM:=785e287f5b5e5c9cce9397f9bce02a22
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,6 +33,9 @@ endef
 
 EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include
 
+CONFIGURE_VARS += \
+       CFLAGS="$(TARGET_CFLAGS) -std=gnu99 -DNO_DEBUG "
+
 CONFIGURE_ARGS += \
        --disable-afs \
        --enable-hfs \
diff --git a/net/netatalk/patches/001-cross_compile.patch b/net/netatalk/patches/001-cross_compile.patch
deleted file mode 100644 (file)
index 917d422..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-diff -Naur netatalk-2.0.5.orig/configure netatalk-2.0.5/configure
---- netatalk-2.0.5.orig/configure      2009-10-05 11:27:29.000000000 +0300
-+++ netatalk-2.0.5/configure   2010-01-31 22:03:19.000000000 +0200
-@@ -26504,10 +26504,7 @@
- if test $ac_cv_lib_afsauthent_pioctl = yes; then
-   netatalk_cv_afs=yes
- else
--  { { echo "$as_me:$LINENO: error: AFS installation not found" >&5
--echo "$as_me: error: AFS installation not found" >&2;}
--   { (exit 1); exit 1; }; }
--
-+  netatalk_cv_afs=yes
- fi
-                               AFS_LIBS=-lresolv -lafsrpc -lafsauthent
-@@ -30832,7 +30829,7 @@
-     trybdbdir=""
-     dobdbsearch=yes
-     bdb_search_dirs="/usr/local /usr"
--    search_subdirs="/ /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4.3 /db43 /db4.2 /db42 /db4.1 /db41 /db4"
-+    search_subdirs="/ /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4.3 /db43 /db4.2 /db42 /db4.1 /db41 /db4 /./"
-         DB_MAJOR_REQ=4
-     DB_MINOR_REQ=1
-@@ -30932,11 +30929,7 @@
-         { echo "$as_me:$LINENO: checking Berkeley DB library ($lib)" >&5
- echo $ECHO_N "checking Berkeley DB library ($lib)... $ECHO_C" >&6; }
-         if test "$cross_compiling" = yes; then
--  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&5
--echo "$as_me: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&2;}
--   { (exit 1); exit 1; }; }
-+   { { echo "$as_me:$LINENO: result yes" >&5; echo "${ECHO_T}yes" >&6; }; }
- else
-   cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h.  */
-@@ -31042,23 +31035,7 @@
-     if test "x$bdbfound" = "xyes"; then
-         :
-     else
--
--              { echo "$as_me:$LINENO: result: " >&5
--echo "${ECHO_T}" >&6; }
--              { echo "$as_me:$LINENO: result: Make sure you have the required Berkeley DB libraries AND headers installed." >&5
--echo "${ECHO_T}Make sure you have the required Berkeley DB libraries AND headers installed." >&6; }
--              { echo "$as_me:$LINENO: result: You can download the latest version from http://www.sleepycat.com." >&5
--echo "${ECHO_T}You can download the latest version from http://www.sleepycat.com." >&6; }
--              { echo "$as_me:$LINENO: result: If you have installed BDB in a non standard location use the" >&5
--echo "${ECHO_T}If you have installed BDB in a non standard location use the" >&6; }
--              { echo "$as_me:$LINENO: result: --with-bdb=/path/to/bdb configure option and make sure" >&5
--echo "${ECHO_T}--with-bdb=/path/to/bdb configure option and make sure" >&6; }
--              { echo "$as_me:$LINENO: result: your linker is configured to check for libraries there." >&5
--echo "${ECHO_T}your linker is configured to check for libraries there." >&6; }
--              { { echo "$as_me:$LINENO: error: Berkeley DB library required but not found!" >&5
--echo "$as_me: error: Berkeley DB library required but not found!" >&2;}
--   { (exit 1); exit 1; }; }
--
-+      :
-     fi
-@@ -31080,6 +31057,7 @@
-     esac
-   done
-   BDB_LIBS=$ac_new_flags
-+  BDB_LIBS="-ldb-4.7"