fix rarpd: revert to plain old ./configure call, Build/Configure/Default does not...
authorNicolas Thill <nico@openwrt.org>
Tue, 8 Aug 2006 15:05:22 +0000 (15:05 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 8 Aug 2006 15:05:22 +0000 (15:05 +0000)
SVN-Revision: 4543

net/rarpd/Makefile

index 17ca1614663342403cd22ecbc7e26e3548aa320d..852d7a0fb6937bee8aaeb4765922ebb0b3142321 100644 (file)
@@ -41,8 +41,34 @@ define Package/rarpd
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--with-libnet="$(STAGING_DIR)/usr" \
-                       --with-pcap="$(STAGING_DIR)/usr",CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)")
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-I$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --with-libnet="$(STAGING_DIR)/usr" \
+                       --with-pcap="$(STAGING_DIR)/usr" \
+       );
 endef
 
 define Build/Compile