Drop ndppd, it moved to the openwrt-oruting feed
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Jul 2013 13:41:40 +0000 (13:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Jul 2013 13:41:40 +0000 (13:41 +0000)
SVN-Revision: 37117

ipv6/ndppd/Makefile [deleted file]
ipv6/ndppd/files/ndppd.init [deleted file]

diff --git a/ipv6/ndppd/Makefile b/ipv6/ndppd/Makefile
deleted file mode 100644 (file)
index b7c3282..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-#
-# Copyright (C) 2007-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ndppd
-PKG_VERSION:=0.2.2
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-
-# Latest release
-PKG_SOURCE_URL:=http://www.priv.nu/projects/ndppd/files/
-PKG_MD5SUM:=d90c4b65777a62274c1837dba341e5a8
-
-# Development snapshot
-#PKG_SOURCE_URL=git://github.com/Tuhox/ndppd.git
-#PKG_SOURCE_VERSION=master
-#PKG_SOURCE_SUBDIR=$(PKG_NAME)-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/uclibc++.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ndppd
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=NDP Proxy Daemon
-  URL:=http://www.priv.nu/projects/ndppd/
-  MAINTAINER:=Gabriel Kerneis <kerneis@pps.jussieu.fr>
-  DEPENDS:=+kmod-ipv6 $(CXX_DEPENDS)
-endef
-
-define Package/ndppd/description
- ndppd, or NDP Proxy Daemon, is a daemon that proxies NDP (Neighbor Discovery
- Protocol) messages between interfaces.  ndppd currently only supports Neighbor
- Solicitation Messages and Neighbor Advertisement Messages.
-
- The ndp_proxy provided by Linux doesn't support listing proxies, and only hosts
- are supported.  No subnets.  ndppd solves this by listening for Neighbor
- Solicitation messages on an interface, then query the internal interfaces for
- that target IP before finally sending a Neighbor Advertisement message.
-endef
-
-define Package/ndppd/conffiles
-/etc/ndppd.conf
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CXX="$(TARGET_CXX)" \
-               CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++0x -fno-rtti" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               LIBS="-lc" \
-               ndppd
-endef
-
-define Package/ndppd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndppd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/ndppd.init $(1)/etc/init.d/ndppd
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/ndppd.conf-dist $(1)/etc/ndppd.conf
-endef
-
-$(eval $(call BuildPackage,ndppd))
diff --git a/ipv6/ndppd/files/ndppd.init b/ipv6/ndppd/files/ndppd.init
deleted file mode 100644 (file)
index 4cf0e8a..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2007-2011 OpenWrt.org
-
-START=90
-
-SERVICE_USE_PID=1
-SERVICE_PID_FILE=/var/run/ndppd.pid
-
-start() {
-       mkdir -p /var/run
-       service_start /usr/sbin/ndppd -p $SERVICE_PID_FILE -d
-}
-
-stop() {
-       service_stop /usr/sbin/ndppd
-}