[packages] utils/at: explicitly pass jobdir and spooldir to configure
authorAndy Boyett <agb@openwrt.org>
Fri, 17 Oct 2008 07:41:26 +0000 (07:41 +0000)
committerAndy Boyett <agb@openwrt.org>
Fri, 17 Oct 2008 07:41:26 +0000 (07:41 +0000)
 - Fixes compilation on hosts without at or cron installed
 - Should fix problems where host location of above dirs varies from OpenWrt location
 - Also add PKG_RELEASE var to makefile

SVN-Revision: 12998

utils/at/Makefile

index f793ffadb92ba5eacdc521a19b9f1cb3a7450301..3f438b23c831692b251ddc93057c64e8e293c185 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,6 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=at
 PKG_VERSION:=3.1.10ubuntu4
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://archive.ubuntu.com/ubuntu/pool/main/a/at
@@ -33,7 +34,8 @@ endef
 export SENDMAIL=/bin/true
 EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include/libelf \
                -L$(STAGING_DIR)/usr/lib
-CONFIGURE_ARGS+=--with-daemon_username=nobody --with-daemon_groupname=nogroup
+CONFIGURE_ARGS+=--with-daemon_username=nobody --with-daemon_groupname=nogroup \
+               --with-jobdir=/var/spool/cron/atjobs --with-atspool=/var/spool/cron/atspool
 
 define Package/at/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/