[packages] krb5: ensure linking against supplied libcom_err (#6508)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 16 Jan 2010 13:55:28 +0000 (13:55 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 16 Jan 2010 13:55:28 +0000 (13:55 +0000)
SVN-Revision: 19170

net/krb5/Makefile
net/krb5/patches/003-krb5kdc-com-err-fix.patch [new file with mode: 0644]

index d17e1d74444395060ed7d782e0fdbf539cdb7efa..80ad248104f29ae03bb531a2f0530296833432b5 100644 (file)
@@ -60,6 +60,7 @@ define Build/Prepare
        tar xzf "$(BUILD_DIR)/krb5-$(PKG_VERSION).tar.gz" -C "$(BUILD_DIR)"
        patch -p1 -d "$(PKG_BUILD_DIR)" < "$(PATCH_DIR)/001-uclibc-symbol-collision-fix.patch"
        patch -p1 -d "$(PKG_BUILD_DIR)" < "$(PATCH_DIR)/002-krb5kdc-dir-to-etc.patch"
+       patch -p1 -d "$(PKG_BUILD_DIR)" < "$(PATCH_DIR)/003-krb5kdc-com-err-fix.patch"
 endef
 
 CONFIGURE_PATH = ./src
diff --git a/net/krb5/patches/003-krb5kdc-com-err-fix.patch b/net/krb5/patches/003-krb5kdc-com-err-fix.patch
new file mode 100644 (file)
index 0000000..d068980
--- /dev/null
@@ -0,0 +1,15 @@
+diff -u --recursive krb5-1.7-vanilla/src/config/shlib.conf krb5-1.7/src/config/shlib.conf
+--- krb5-1.7-vanilla/src/config/shlib.conf     2008-12-08 17:33:07.000000000 -0500
++++ krb5-1.7/src/config/shlib.conf     2010-01-15 22:04:16.345151448 -0500
+@@ -409,9 +409,9 @@
+       SHLIBEXT=.so
+       # Linux ld doesn't default to stuffing the SONAME field...
+       # Use objdump -x to examine the fields of the library
+-      LDCOMBINE='$(CC) -shared -fPIC -Wl,-h,$(LIBPREFIX)$(LIBBASE)$(SHLIBSEXT),--no-undefined $(LDFLAGS)'
++      LDCOMBINE='$(CC) -shared -fPIC -Wl,-h,$(LIBPREFIX)$(LIBBASE)$(SHLIBSEXT),--no-undefined'
+       # 
+-      LDCOMBINE_TAIL='-Wl,--version-script binutils.versions && $(PERL) -w $(SRCTOP)/util/export-check.pl $(SHLIB_EXPORT_FILE) $@'
++      LDCOMBINE_TAIL='-Wl,--version-script binutils.versions $(LDFLAGS) && $(PERL) -w $(SRCTOP)/util/export-check.pl $(SHLIB_EXPORT_FILE) $@'
+       SHLIB_EXPORT_FILE_DEP=binutils.versions
+       # For cases where we do have dependencies on other libraries
+       # built in this tree...