[package] update wifidog to 20090925 (#5902)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 27 Sep 2009 13:04:48 +0000 (13:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 27 Sep 2009 13:04:48 +0000 (13:04 +0000)
SVN-Revision: 17759

net/wifidog/Makefile
net/wifidog/files/wifidog.init
net/wifidog/patches/001-proc_net_syntax.patch [deleted file]

index 15cf8359eacf7b0c34cd9d499d8ee6fec874c010..b313aba75d010099343489d50d175ee09dda4389 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifidog
-PKG_VERSION:=1.1.5
-PKG_RELEASE:=2
+PKG_VERSION:=20090925
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= @SF/$(PKG_NAME)
-PKG_MD5SUM:=abe5f7123179a0f08c493ce59fb3cb31
+PKG_MD5SUM:=e3ecacba67a91b6ea3c1072ba6c5a0b4
 
 PKG_FIXUP = libtool
 
@@ -52,6 +52,7 @@ define Package/wifidog/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhttpd.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/wifidog.conf $(1)/etc/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/wifidog-msg.html $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/wifidog
 endef
index 9ef9f586bd7b776679ba983c28301479228ef35b..9db075db783efbe49e204009f3bd39c523641411 100644 (file)
@@ -1,6 +1,8 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006 OpenWrt.org
-START=50
+START=65
+EXTRA_COMMANDS="status"
+EXTRA_HELP="        status Print the status of the service"
 
 start() {
        /usr/bin/wifidog-init start
@@ -10,3 +12,6 @@ stop() {
        /usr/bin/wifidog-init stop
 }
 
+status() {
+       /usr/bin/wifidog-init status
+}
\ No newline at end of file
diff --git a/net/wifidog/patches/001-proc_net_syntax.patch b/net/wifidog/patches/001-proc_net_syntax.patch
deleted file mode 100644 (file)
index fb50736..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- wifidog-1.1.5/src/firewall.c       2008-08-29 22:44:57.000000000 +0200
-+++ wifidog-1.1.5-fixed/src/firewall.c 2008-08-29 22:45:46.000000000 +0200
-@@ -135,7 +135,7 @@
-        /* Find ip, copy mac in reply */
-        reply = NULL;
--    while (!feof(proc) && (fscanf(proc, " %15[0-9.] %*s %*s %17[A-F0-9:] %*s %*s", ip, mac) == 2)) {
-+    while (!feof(proc) && (fscanf(proc, " %15[0-9.] %*s %*s %17[A-Fa-f0-9:] %*s %*s", ip, mac) == 2)) {
-                 if (strcmp(ip, req_ip) == 0) {
-                               reply = safe_strdup(mac);
-                               break;