sigscheme: new package in lang section
authorGabor Juhos <juhosg@openwrt.org>
Sun, 16 May 2010 13:13:23 +0000 (13:13 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 16 May 2010 13:13:23 +0000 (13:13 +0000)
this patch adds a new package in the lang section:

http://code.google.com/p/sigscheme/

SigScheme is a R5RS Scheme interpreter for embedded use. It features
small footprint (64KB in library form on the 'small' configuration)
like SIOD and TinyScheme, low memory consumption (2-words per cons
cell), multibyte characters handling (UTF-8, EUCs and Shift_JIS) and
more.

-Raphael

SVN-Revision: 21473

lang/sigscheme/Makefile [new file with mode: 0644]

diff --git a/lang/sigscheme/Makefile b/lang/sigscheme/Makefile
new file mode 100644 (file)
index 0000000..10c6dca
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sigscheme
+PKG_VERSION:=0.8.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://sigscheme.googlecode.com/files/
+PKG_MD5SUM:=f25b0acbb854651b375b42f17ad20f39
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sigscheme
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=SigScheme
+  URL:=http://code.google.com/p/sigscheme/
+endef
+
+define Package/sigscheme/description
+SigScheme is a R5RS Scheme interpreter for embedded use. It features small
+footprint (64KB in library form on the 'small' configuration) like SIOD and
+TinyScheme, low memory consumption (2-words per cons cell), multibyte characters
+handling (UTF-8, EUCs and Shift_JIS) and more.
+endef
+
+define Package/sigscheme/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{gcroots,sscm}.so.* $(1)/usr/lib
+
+       $(INSTALL_DIR) $(1)/usr/share
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/sigscheme/ $(1)/usr/lib
+
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/sscm $(1)/usr/bin
+endef
+
+$(eval $(call BuildPackage,sigscheme))