ar71xx: create smaller sysupgrade images for the WRT400N board
authorGabor Juhos <juhosg@openwrt.org>
Mon, 26 Apr 2010 18:27:54 +0000 (18:27 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 26 Apr 2010 18:27:54 +0000 (18:27 +0000)
SVN-Revision: 21170

target/linux/ar71xx/image/Makefile

index dfcc5f6f08d1d960ce15c461ad3950658e2ff7c3..adb4002de350263935ad2abadb6885868a08ee28 100644 (file)
@@ -81,10 +81,9 @@ define Image/Build/WRT400N
                        -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
                ( \
                        dd if=$(KDIR)/vmlinux-$(2).uImage bs=1280k conv=sync; \
-                       dd if=$(KDIR)/root.$(1) bs=6336k conv=sync; \
-                       echo -n $(4); \
-               ) > $(call imgname,$(1),$(2)).bin; \
-               wrt400n $(KDIR)/vmlinux-$(2).uImage $(KDIR)/root.$(1) $(call imgname,$(1),$(2)).webui; \
+                       dd if=$(KDIR)/root.$(1) \
+               ) > $(call imgname,$(1),$(2))-sysupgrade.bin; \
+               wrt400n $(KDIR)/vmlinux-$(2).uImage $(KDIR)/root.$(1) $(call imgname,$(1),$(2))-factory.bin; \
        fi; fi
 endef