remove the now unused Target-Kernel field from the target metadata
authorFelix Fietkau <nbd@openwrt.org>
Mon, 30 May 2011 23:07:53 +0000 (23:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 30 May 2011 23:07:53 +0000 (23:07 +0000)
SVN-Revision: 27033

include/target.mk
scripts/metadata.pl

index 83455723eaf16e3712965c5fd94d689746fa2ca5..676b983271b29220cb74dab61170b978c0792ec9 100644 (file)
@@ -202,7 +202,6 @@ define BuildTargets/DumpCurrent
   dumpinfo:
        @echo 'Target: $(TARGETID)'; \
         echo 'Target-Board: $(BOARD)'; \
-        echo 'Target-Kernel: $(KERNEL)'; \
         echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),$(if $(SUBTARGET),))'; \
         echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
         echo 'Target-Arch: $(ARCH)'; \
index 3de408798004b6df53d40daf4c77c266475c89b2..138232f435ee4dd6c5aa4eb0ed25ea0a5660c2b5 100755 (executable)
@@ -45,7 +45,6 @@ sub parse_target_metadata() {
                                $target->{parent} = $target{$1};
                        }
                };
-               /^Target-Kernel:\s*(\d+\.\d+)\s*$/ and $target->{kernel} = $1;
                /^Target-Name:\s*(.+)\s*$/ and $target->{name} = $1;
                /^Target-Path:\s*(.+)\s*$/ and $target->{path} = $1;
                /^Target-Arch:\s*(.+)\s*$/ and $target->{arch} = $1;