tools/ipkg-utils: calculate installed size from embedded data.tar.gz, makes opkg...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 16 Jan 2011 22:16:49 +0000 (22:16 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 16 Jan 2011 22:16:49 +0000 (22:16 +0000)
SVN-Revision: 25021

tools/ipkg-utils/Makefile
tools/ipkg-utils/patches/180-add_installed_size.patch [new file with mode: 0644]

index 48eb7e37951b557e18334130a54716f5b3e36a11..778260921e118e52e5520de1a2a67a55b10806a8 100644 (file)
@@ -12,7 +12,6 @@ PKG_VERSION:=1.7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://handhelds.org/packages/ipkg-utils/
 PKG_MD5SUM:=da3e3ef772973d7370a6ac95f0fef9b8
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://handhelds.org/packages/ipkg-utils/
 PKG_MD5SUM:=da3e3ef772973d7370a6ac95f0fef9b8
-PKG_CAT:=zcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
diff --git a/tools/ipkg-utils/patches/180-add_installed_size.patch b/tools/ipkg-utils/patches/180-add_installed_size.patch
new file mode 100644 (file)
index 0000000..6ee7de8
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/ipkg-build
++++ b/ipkg-build
+@@ -250,6 +250,11 @@ mkdir $tmp_dir
+ echo $CONTROL > $tmp_dir/tarX
+ ( cd $pkg_dir && $TAR $ogargs -X $tmp_dir/tarX -czf $tmp_dir/data.tar.gz . )
++
++installed_size=`du -b $tmp_dir/data.tar.gz | cut -f1`
++sed -i -e "s/^Installed-Size: .*/Installed-Size: $installed_size/" \
++      $pkg_dir/$CONTROL/control
++
+ ( cd $pkg_dir/$CONTROL && $TAR $ogargs -czf $tmp_dir/control.tar.gz . )
+ rm $tmp_dir/tarX