[imagebuilder] fix custom package selection
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 13 Feb 2010 01:56:48 +0000 (01:56 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 13 Feb 2010 01:56:48 +0000 (01:56 +0000)
SVN-Revision: 19623

target/imagebuilder/files/Makefile

index fe503118b015a14839f1ef0fb8c519cd0379b314..f73642b6ad6fcc7b66f33d5ef18f4e4326f4ae2b 100644 (file)
@@ -81,7 +81,7 @@ $(TOPDIR)/tmp/ipkg.conf: FORCE
        @echo 'dest root /' > $@
        @echo 'src packages file:$(PACKAGE_DIR)' >> $@
 
-BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $($(PROFILE)_PACKAGES) kernel)
+BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $(PACKAGES) $($(PROFILE)_PACKAGES) kernel)
 # "-pkgname" in the package list means remove "pkgname" from the package list
 BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))