clearsilver: fix building on non-linux systems
authorFelix Fietkau <nbd@openwrt.org>
Tue, 15 Apr 2014 17:11:39 +0000 (17:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 15 Apr 2014 17:11:39 +0000 (17:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40513

libs/clearsilver/Makefile

index 40a567c13576595ab4c97415347d61807825521c..52d6ddc8c05b6e4726af9104518e67b2852d7aa4 100644 (file)
@@ -88,7 +88,8 @@ TARGET_CFLAGS+=$(FPIC)
 MAKE_FLAGS+= \
        $(TARGET_CONFIGURE_OPTS) \
        AR="$(AR) cr" \
-       LD="$(TARGET_CC) -o"
+       LD="$(TARGET_CC) -o" \
+       OSTYPE=Linux
 
 define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/