uci: update to git head
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 22 Apr 2013 14:52:28 +0000 (14:52 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 22 Apr 2013 14:52:28 +0000 (14:52 +0000)
  - fixes memory leak in libuci when trying to open not existing configurations
  - fixes memory leak in libuci-lua when querying not existing sections or options
  - fixes handling of filenames with leading underscore

SVN-Revision: 36377

package/uci/Makefile

index 029e63615748fc6dd18266ff9735ffb385e673f5..ffc7c4842556e400cf8dc9c976e3e64836bc516a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,20 +7,20 @@
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=2013-01-04
+UCI_VERSION=2013-04-22
 UCI_RELEASE=1
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
 PKG_RELEASE:=1
-PKG_REV:=e4516d01a7d2b0a5a8def7b5791c7d4032138287
+PKG_REV:=ef12e67516d224e9cd2ca3fd293dbe5ab385c75a
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://nbd.name/uci.git
 PKG_SOURCE_SUBDIR:=uci-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
-PKG_MIRROR_MD5SUM:=c7c4fd6723b607ae7fa039a1078fe7d5
+PKG_MIRROR_MD5SUM:=6d240e8c48bc94f696b8080c0ce7659b
 
 PKG_LICENSE:=LGPLv2.1 GPLv2
 PKG_LICENSE_FILES:=