[package] fix miniupnpd compilation with iptables-1.4.3.2 (#5047)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 4 May 2009 20:19:12 +0000 (20:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 4 May 2009 20:19:12 +0000 (20:19 +0000)
SVN-Revision: 15603

net/miniupnpd/Makefile

index e9073b639afbd9d2f3e869d7f98842c56ddb8ef8..a479b78b0db5e3f45aec7da2b12b49672ae33270 100644 (file)
@@ -6,10 +6,11 @@
 #
 
 include $(TOPDIR)/rules.mk
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
 PKG_VERSION:=1.3
 
 PKG_NAME:=miniupnpd
 PKG_VERSION:=1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=b5e70e80dcf45b424b8fe3c966bdc613
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_MD5SUM:=b5e70e80dcf45b424b8fe3c966bdc613
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
@@ -30,7 +31,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
                $(TARGET_CONFIGURE_OPTS) \
                STAGING_DIR="$(STAGING_DIR)" \
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.openwrt \
                $(TARGET_CONFIGURE_OPTS) \
                STAGING_DIR="$(STAGING_DIR)" \
-               CFLAGS="$(TARGET_CFLAGS) -I $(STAGING_DIR)/usr/include -DIPTABLES_143" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(KERNEL_BUILD_DIR)/iptables-1.4.3.2/include -DIPTABLES_143" \
                LIBS="$(STAGING_DIR)/usr/lib/libiptc.so"
 endef
 
                LIBS="$(STAGING_DIR)/usr/lib/libiptc.so"
 endef