[packages] wide-dhcpv6: fix second instance of endian detection as well (#10648)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 20 Dec 2011 19:20:09 +0000 (19:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 20 Dec 2011 19:20:09 +0000 (19:20 +0000)
SVN-Revision: 29589

ipv6/wide-dhcpv6/Makefile
ipv6/wide-dhcpv6/files/dhcp6c.init

index bdb74cc03d807b3c2021438a699a51e298113c2c..04f13264da869e953bb045b04edf056e170b3d4b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wide-dhcpv6
 PKG_VERSION:=20080615
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
index b60b45b0e31cba5a08375549f46b9cedf33e740d..12248109e96884d73dbd793d0195886915b05997 100644 (file)
@@ -51,7 +51,7 @@ dhcp6c_write_duid() {
                        local len_lo=$(printf "%02x" $((${#len_id} % 0xFF)) )
 
                        # low endian
-                       if [ "$(printf \\1 | hexdump -n1 -ve '8/2 "%04x"')" = "0001" ]; then
+                       if [ "$(printf \\1 | hexdump -n1 -ve '8/2 "" "%04x" ""')" = "0001" ]; then
                                printf \\x$len_lo\\x$len_hi
 
                        # big endian