projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
|
inline
| side by side (parent:
a816933
)
packages: fixed darkstat compile and cleaned whitespace
author
Andy Boyett
<agb@openwrt.org>
Mon, 17 Dec 2007 10:21:16 +0000
(10:21 +0000)
committer
Andy Boyett
<agb@openwrt.org>
Mon, 17 Dec 2007 10:21:16 +0000
(10:21 +0000)
SVN-Revision: 9786
net/darkstat/Makefile
patch
|
blob
|
history
diff --git
a/net/darkstat/Makefile
b/net/darkstat/Makefile
index f9ed8b03cdf7218138d3f40b82eb3767ecd6c8f6..ce632335948733f4702b7f81fd9f969ff1165e5f 100644
(file)
--- a/
net/darkstat/Makefile
+++ b/
net/darkstat/Makefile
@@
-33,7
+33,10
@@
define Package/darkstat/description
A free open source utility for bandwith monitoring \ over web
endef
A free open source utility for bandwith monitoring \ over web
endef
-define Build/Compile
+CONFIGURE_ARGS += \
+ --with-chroot-dir /var/empty
+
+define Build/Compile
mkdir -p $(PKG_INSTALL_DIR)
$(HOSTCC) $(PKG_BUILD_DIR)/static/c-ify.c \
-o $(PKG_BUILD_DIR)/c-ify
mkdir -p $(PKG_INSTALL_DIR)
$(HOSTCC) $(PKG_BUILD_DIR)/static/c-ify.c \
-o $(PKG_BUILD_DIR)/c-ify
@@
-42,7
+45,7
@@
define Build/Compile
all install
endef
all install
endef
-define Package/darkstat/install
+define Package/darkstat/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/darkstat $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/darkstat $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/init.d