- bump nagios to 2.10
authorMartin Janitschke <noeoeh@web.de>
Thu, 6 Mar 2008 23:45:08 +0000 (23:45 +0000)
committerMartin Janitschke <noeoeh@web.de>
Thu, 6 Mar 2008 23:45:08 +0000 (23:45 +0000)
- fix install path for nagios (files are now in the right places,
  not any more in /ipkg-install/... )
- little cleanup of both Makefiles

SVN-Revision: 10549

net/nagios-plugins/Makefile
net/nagios/Makefile

index ae2948a337936b766b225f286acb1cc83c33bdff..90c08193d4b68c069e44a5d086190220df995798 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -25,32 +25,28 @@ comma:= ,
 define Package/nagios-plugins
   SECTION:=net
   CATEGORY:=Network
 define Package/nagios-plugins
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Monitoring
   DEPENDS:=+uclibcxx
   TITLE:=plugins for Nagios checks
   URL:=http://nagiosplug.sourceforge.net/
 endef
 
   DEPENDS:=+uclibcxx
   TITLE:=plugins for Nagios checks
   URL:=http://nagiosplug.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-mysql \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --with-ping-command="/bin/ping -c %d %s" \
-               --with-ps-command="/bin/ps -Aopid" \
-               --with-ps-cols="6" \
-               --with-ps-format="%d %s %d %s %s %n" \
-               --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
-               --with-uptime-command="/usr/bin/uptime" \
-               --with-ssh-command="/usr/bin/ssh" \
-               --with-nslookup-command="/usr/bin/nslookup" \
-               , \
-       )
-endef
+CONFIGURE_ARGS += \
+       --without-mysql \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-ping-command="/bin/ping -c %d %s" \
+       --with-ps-command="/bin/ps -Aopid" \
+       --with-ps-cols="6" \
+       --with-ps-format="%d %s %d %s %s %n" \
+       --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
+       --with-uptime-command="/usr/bin/uptime" \
+       --with-ssh-command="/usr/bin/ssh" \
+       --with-nslookup-command="/usr/bin/nslookup"
 
 define Build/Compile
 
 define Build/Compile
-       $(call Build/Compile/Default,\
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               all install
 endef
 
 define Package/nagios-plugins/install
 endef
 
 define Package/nagios-plugins/install
index 6fa176571ea950e0d016e6424c22e0ba48cadb13..6a98d584dc66785237f4e5341eb13836afa02219 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nagios
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nagios
-PKG_VERSION:=2.9
+PKG_VERSION:=2.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
-PKG_MD5SUM:=b6e3a21c91edb063c00712c6001e15ec
+PKG_MD5SUM:=8c3a29e138f2ff8c8abbd3dd8a40c4b6
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -25,7 +25,8 @@ PKG_BUILD_DEPENDS:=libnotimpl
 define Package/nagios
   SECTION:=net
   CATEGORY:=Network
 define Package/nagios
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpthread +microperl
+  SUBMENU:=Monitoring
+  DEPENDS:=+libpthread +microperl +libltdl
   TITLE:=service and network monitoring program
   URL:=http://www.nagios.org/
 endef
   TITLE:=service and network monitoring program
   URL:=http://www.nagios.org/
 endef
@@ -34,31 +35,35 @@ define Package/nagios/description
        service and network monitoring program
 endef
 
        service and network monitoring program
 endef
 
-define Package/send-nagios/conffiles
-/etc/send_nagios.cfg
-endef
-
 EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 
 EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --with-nagios-user="root" \
-               --with-nagios-group="root", \
-               CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
-               LIBS="-lnotimpl" \
-       )
-endef
+CONFIGURE_ARGS += \
+       --with-nagios-user="root" \
+       --with-nagios-group="root" \
+       --sysconfdir="/etc/nagios" \
+       --without-gd-lib \
+       --without-gd-inc \
+       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)"
+       
+CONFIGURE_VARS += \
+       LIBS="-lnotimpl"
 
 define Build/Compile
 
 define Build/Compile
-       $(call Build/Compile/Default,\
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL_OPTS="" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL_OPTS="" \
-               all install install-config \
-       )
+               all install install-config
 endef
 
 define Package/nagios/install
 endef
 
 define Package/nagios/install
-       $(CP) $(PKG_INSTALL_DIR) $(1)/
+       $(INSTALL_DIR)  $(1)/etc/nagios
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/nagios/* $(1)/etc/nagios/
+       $(INSTALL_DIR)  $(1)/usr/bin
+       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/bin/{nagios,nagiostats} $(1)/usr/bin/
+       $(INSTALL_DIR)  $(1)/usr/sbin
+       $(INSTALL_BIN)  $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(INSTALL_DIR)  $(1)/usr/share
+       $(CP)   $(PKG_INSTALL_DIR)/usr/share/* $(1)/usr/share/
 endef
 
 $(eval $(call BuildPackage,nagios))
 endef
 
 $(eval $(call BuildPackage,nagios))