[package] update keepalived to 1.1.17 (#5415)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 26 Jun 2009 20:14:38 +0000 (20:14 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 26 Jun 2009 20:14:38 +0000 (20:14 +0000)
SVN-Revision: 16571

net/keepalived/Makefile
net/keepalived/patches/010-cross_compile_force_vrrp_on.patch [deleted file]

index fa37ffd5409ce31b3040bd33b233a16f74cfd928..6aa0555b1b255adcf6a47a0a961f9e149c0bc76c 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keepalived
-PKG_VERSION:=1.1.15
+PKG_VERSION:=1.1.17
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= http://www.keepalived.org/software
-PKG_MD5SUM:=4c93f5d8b6bfabe84b02828a5bbb7aa0
+PKG_MD5SUM:=324ef61a9eed389679f0a05edd1d1323
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -32,7 +32,7 @@ define Package/keepalived/description
 endef
 
 define Package/keepalived/conffiles
- /etc/keepalived/keepalived.conf
+/etc/keepalived/keepalived.conf
 endef
 
 acvar=$(subst -,_,$(subst .,_,$(subst /,_,$(1))))
@@ -60,11 +60,11 @@ endef
 
 define Package/keepalived/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc/keepalived
-       $(CP) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/keepalived.conf
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/keepalived.init $(1)/etc/init.d/keepalived
 endef
diff --git a/net/keepalived/patches/010-cross_compile_force_vrrp_on.patch b/net/keepalived/patches/010-cross_compile_force_vrrp_on.patch
deleted file mode 100644 (file)
index bb8d72a..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur keepalived-1.1.15/configure keepalived-1.1.15.mod/configure
---- keepalived-1.1.15/configure        2006-10-10 05:20:35.000000000 -0400
-+++ keepalived-1.1.15.mod/configure    2009-05-08 04:52:13.000000000 -0400
-@@ -3928,7 +3928,7 @@
--VRRP_SUPPORT="_WITHOUT_VRRP_"
-+VRRP_SUPPORT="_WITH_VRRP_"
- if test "$enable_vrrp" != "no"; then
-   echo "$as_me:$LINENO: checking for kernel netlink support" >&5
- echo $ECHO_N "checking for kernel netlink support... $ECHO_C" >&6