[ramips] adds mach type for fonera20n
authorJohn Crispin <john@openwrt.org>
Sat, 24 Oct 2009 20:55:36 +0000 (20:55 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 24 Oct 2009 20:55:36 +0000 (20:55 +0000)
SVN-Revision: 18132

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/rt305x_regs.h
target/linux/ramips/files/arch/mips/ralink/common/prom.c
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-fonera20n.c [new file with mode: 0644]

index a17962d5aaaab0e5538f391f291f995bdb157640..4056b163de1a8574454d834972842c81d1a93492 100644 (file)
@@ -41,7 +41,7 @@
 #define RT305X_UART0_SIZE      0x100
 #define RT305X_UART1_SIZE      0x100
 #define RT305X_FLASH1_SIZE     (16 * 1024 * 1024)
-#define RT305X_FLASH0_SIZE     (4 * 1024 * 1024)
+#define RT305X_FLASH0_SIZE     (8 * 1024 * 1024)
 
 /* SYSC registers */
 #define SYSC_REG_CHIP_NAME0    0x000   /* Chip Name 0 */
index 20b8d5fb6472aa81cead6c49b282315207660ae6..587f1611077edb02b3286c020361100660f7953b 100644 (file)
@@ -41,6 +41,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "WHR-G300N",
                .mach_type      = RAMIPS_MACH_WHR_G300N,
+       }, {
+               .name           = "FONERA20N",
+               .mach_type      = RAMIPS_MACH_FONERA20N,
        }
 };
 
index 383f79d2b609c16b0824d74713bcca54c8372952..ef52c05df9c1315437101587851d476c9c23590b 100644 (file)
@@ -17,6 +17,11 @@ config RT305X_MACH_V22RW_2X2
        default y
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_FONERA20N
+       bool "La Fonera20N board support"
+       default y
+       select RALINK_DEV_GPIO_LEDS
+
 endmenu
 
 endif
index 4eeaf213901560d4a3be54c807903a64bec9754c..a1278c3057bb8ca1ef514e27ab63c6c4978f3fcb 100644 (file)
@@ -14,3 +14,4 @@ obj-$(CONFIG_EARLY_PRINTK)            += early_printk.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
+obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-fonera20n.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-fonera20n.c
new file mode 100644 (file)
index 0000000..3a444ca
--- /dev/null
@@ -0,0 +1,100 @@
+/*
+ *  La Fonera20N board support
+ *
+ *  Copyright (C) 2009 John Crispin <blogic@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+#include <linux/leds.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev_gpio_leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define FONERA20N_GPIO_BUTTON_RESET    12
+#define FONERA20N_GPIO_SWITCH          13
+#define FONERA20N_GPIO_LED_WIFI                7
+#define FONERA20N_GPIO_LED_POWER       9
+#define FONERA20N_GPIO_LED_USB         14
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition fonera20n_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "u-boot-env",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0a0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x150000,
+               .size   = 0x6b0000,
+       }, {
+               .name   = "openwrt",
+               .offset = 0x050000,
+               .size   = 0x7b0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data fonera20n_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(fonera20n_partitions),
+       .parts          = fonera20n_partitions,
+#endif
+};
+
+static struct gpio_led fonera20n_leds_gpio[] __initdata = {
+       {
+               .name           = "fonera20n:orange:wifi",
+               .gpio           = FONERA20N_GPIO_LED_WIFI,
+               .active_low     = 1,
+       }, {
+               .name           = "fonera20n:green:power",
+               .gpio           = FONERA20N_GPIO_LED_POWER,
+               .active_low     = 1,
+       }, {
+               .name           = "fonera20n:orange:usb",
+               .gpio           = FONERA20N_GPIO_LED_USB,
+               .active_low     = 1,
+       }
+};
+
+static void __init fonera20n_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_register_flash(0, &fonera20n_flash_data);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(fonera20n_leds_gpio),
+                                 fonera20n_leds_gpio);
+
+       rt305x_register_ethernet();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_FONERA20N, "La Fonera 2.0N", fonera20n_init);