Port xsupplicant to -ng
authorFlorian Fainelli <florian@openwrt.org>
Tue, 8 Aug 2006 09:22:06 +0000 (09:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 8 Aug 2006 09:22:06 +0000 (09:22 +0000)
SVN-Revision: 4521

net/xsupplicant/Makefile [new file with mode: 0644]
net/xsupplicant/patches/001-no-lfl.patch [new file with mode: 0644]
net/xsupplicant/patches/002-cardif_madwifi_driver_h.patch [new file with mode: 0644]
net/xsupplicant/patches/004-madwifi-ng.patch [new file with mode: 0644]
net/xsupplicant/patches/005-disable-procfs-check.patch [new file with mode: 0644]

diff --git a/net/xsupplicant/Makefile b/net/xsupplicant/Makefile
new file mode 100644 (file)
index 0000000..d118274
--- /dev/null
@@ -0,0 +1,93 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xsupplicant
+PKG_VERSION:=1.2.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=c9b17b2e1879bac85c583980338fed85
+
+PKG_SOURCE_URL:=@SF/open1x
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/xsupplicant
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenssl +wireless-tools
+  TITLE:=A fully compliant 802.1x authenticator
+  DESCRIPTION:=This software allows a GNU/Linux or BSD workstation to authenticate with\\\
+       a RADIUS server using 802.1x and various EAP protocols.\\\
+  URL:=http://open1x.sourceforge.net/
+endef
+
+define Package/xsupplicant/conffiles
+/etc/xsupplicant.conf
+endef
+
+define Build/Configure 
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+               touch configure.in; \
+               touch aclocal.m4; \
+               touch Makefile.in; \
+               touch configure; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include \
+                       -I$(PKG_BUILD_DIR)/lib/libxsupconfig/ \
+                       -I$(STAGING_DIR)/usr/include/madwifi" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --with-openssl="$(STAGING_DIR)/usr" \
+                       --with-madwifi-path="$(STAGING_DIR)/usr/include/madwifi" \
+       );
+endef
+
+define Build/Compile   
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR=$(PKG_INSTALL_DIR) \
+               all install
+endef
+
+define Package/xsupplicant/install     
+       install -d -m0755 $(1)/etc
+       install -m0644 $(PKG_BUILD_DIR)/etc/xsupplicant.conf $(1)/etc/
+       install -d -m0755 $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/xsup_* $(1)/usr/bin/
+       install -d -m0755 $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/xsupplicant $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,xsupplicant))
diff --git a/net/xsupplicant/patches/001-no-lfl.patch b/net/xsupplicant/patches/001-no-lfl.patch
new file mode 100644 (file)
index 0000000..9f0ed94
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN xsupplicant-1.2.2-old/configure xsupplicant-1.2.2-new/configure
+--- xsupplicant-1.2.2-old/configure    2005-09-14 05:34:54.000000000 +0200
++++ xsupplicant-1.2.2-new/configure    2005-10-20 06:24:23.000000000 +0200
+@@ -3316,7 +3316,7 @@
+ fi
+  if test -n "$LEX"; then
+        LFLAGS="$LFLAGS -i"
+-       MORELIBS="${MORELIBS} -lfl"
++
+  fi
+ echo "$as_me:$LINENO: checking whether byte ordering is bigendian" >&5
+diff -ruN xsupplicant-1.2.2-old/configure.in xsupplicant-1.2.2-new/configure.in
+--- xsupplicant-1.2.2-old/configure.in 2005-09-14 05:34:54.000000000 +0200
++++ xsupplicant-1.2.2-new/configure.in 2005-10-20 06:23:38.000000000 +0200
+@@ -17,7 +17,7 @@
+ AM_PROG_LEX
+  if test -n "$LEX"; then
+        LFLAGS="$LFLAGS -i"
+-       MORELIBS="${MORELIBS} -lfl"
++
+  fi 
+ AC_C_BIGENDIAN([big_endian=true;AC_DEFINE(BIGENDIAN)],[big_endian=false;AC_DEFINE(LILENDIAN)])
diff --git a/net/xsupplicant/patches/002-cardif_madwifi_driver_h.patch b/net/xsupplicant/patches/002-cardif_madwifi_driver_h.patch
new file mode 100644 (file)
index 0000000..4333d34
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ruN xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.h xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.h
+--- xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.h     2005-04-06 04:21:53.000000000 +0200
++++ xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.h     2005-10-17 22:03:19.000000000 +0200
+@@ -21,6 +21,7 @@
+ int cardif_madwifi_driver_set_key(char *, int, unsigned char *, int, int, 
+                                char *, int, char *, int);
+ int cardif_madwifi_driver_wpa_state(struct interface_data *, char);
++void cardif_madwifi_driver_associate(struct interface_data *, char *);
+ int cardif_madwifi_driver_disassociate(struct interface_data *, int);
+ #endif // _CARDIF_MADWIFI_DRIVER_H_
diff --git a/net/xsupplicant/patches/004-madwifi-ng.patch b/net/xsupplicant/patches/004-madwifi-ng.patch
new file mode 100644 (file)
index 0000000..7c009bc
--- /dev/null
@@ -0,0 +1,28 @@
+diff -ruN xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.c xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.c
+--- xsupplicant-1.2.2-old/src/cardif/linux/cardif_madwifi_driver.c     2005-10-13 20:57:28.000000000 +0200
++++ xsupplicant-1.2.2-new/src/cardif/linux/cardif_madwifi_driver.c     2005-10-23 19:28:46.000000000 +0200
+@@ -140,19 +140,19 @@
+       "ioctl[IEEE80211_IOCTL_SETKEY]",
+       "ioctl[IEEE80211_IOCTL_GETKEY]",
+       "ioctl[IEEE80211_IOCTL_DELKEY]",
+-      NULL,
++      "ioctl[IEEE80211_IOCTL_SETWMMPARAMS]",
+       "ioctl[IEEE80211_IOCTL_SETMLME]",
+-      NULL,
++      "ioctl[IEEE80211_IOCTL_GETCHANINFO]",
+       "ioctl[IEEE80211_IOCTL_SETOPTIE]",
+       "ioctl[IEEE80211_IOCTL_GETOPTIE]",
+       "ioctl[IEEE80211_IOCTL_ADDMAC]",
+       NULL,
+       "ioctl[IEEE80211_IOCTL_DELMAC]",
+-      NULL,
+-      "ioctl[IEEE80211_IOCTL_CHANLIST]",
++      "ioctl[IEEE80211_IOCTL_GETCHANLIST]",
++      "ioctl[IEEE80211_IOCTL_SETCHANLIST]",
+       };
+       if (IEEE80211_IOCTL_SETPARAM <= op &&
+-        op <= IEEE80211_IOCTL_CHANLIST)
++        op <= IEEE80211_IOCTL_SETCHANLIST)
+       debug_printf(DEBUG_NORMAL, "%s\n", opnames[op - SIOCIWFIRSTPRIV]);
+       else
+       debug_printf(DEBUG_NORMAL, "ioctl[unknown???]");
diff --git a/net/xsupplicant/patches/005-disable-procfs-check.patch b/net/xsupplicant/patches/005-disable-procfs-check.patch
new file mode 100644 (file)
index 0000000..b9dab9c
--- /dev/null
@@ -0,0 +1,23 @@
+diff -Nur xsupplicant-1.2.2/configure xsupplicant-1.2.2.patched/configure
+--- xsupplicant-1.2.2/configure        2005-09-14 05:34:54.000000000 +0200
++++ xsupplicant-1.2.2.patched/configure        2005-12-23 23:51:47.031541500 +0100
+@@ -4809,19 +4809,6 @@
+   FRAMER="generic"
+ fi
+-if test $FRAMER = "linux"; then
+-   echo "$as_me:$LINENO: checking for procfs support" >&5
+-echo $ECHO_N "checking for procfs support... $ECHO_C" >&6
+-   if test -r /proc/net/dev; then
+-      echo "$as_me:$LINENO: result: okay" >&5
+-echo "${ECHO_T}okay" >&6
+-   else
+-      { { echo "$as_me:$LINENO: error: You must have ProcFS enabled in your kernel!" >&5
+-echo "$as_me: error: You must have ProcFS enabled in your kernel!" >&2;}
+-   { (exit 1); exit 1; }; };
+-   fi
+-fi
+-
+ if test "$MADWIFI_PATH" != ""; then
+    echo "$as_me:$LINENO: result: Adding MADWIFI WPA support." >&5
+ echo "${ECHO_T}Adding MADWIFI WPA support." >&6