Fix httping compilation
authorFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 10:22:09 +0000 (10:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 10:22:09 +0000 (10:22 +0000)
SVN-Revision: 6399

net/httping/Makefile
net/httping/patches/02-version.patch [new file with mode: 0644]

index 0d8692d54f1c3b583453750a3a8442f08ec2563d..e5d4d198658ddd8a9480b4d9ee1e039c8f93bc8a 100644 (file)
@@ -34,7 +34,9 @@ define Package/httping
 endef
 
 define Build/Compile
-       $(call Build/Compile/Default)
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       )
 endef
 
 define Package/httping/install 
diff --git a/net/httping/patches/02-version.patch b/net/httping/patches/02-version.patch
new file mode 100644 (file)
index 0000000..1a5db8e
--- /dev/null
@@ -0,0 +1,30 @@
+diff -urN httping-1.0.10/main.c httping-1.0.10.new/main.c
+--- httping-1.0.10/main.c      2006-01-02 17:07:29.000000000 +0100
++++ httping-1.0.10.new/main.c  2007-02-27 11:14:32.000000000 +0100
+@@ -38,6 +38,8 @@
+ #include "utils.h"
+ #include "error.h"
++#define VERSION "1.0.10"
++
+ static volatile int stop = 0;
+ int quiet = 0;
+@@ -48,7 +50,7 @@
+ void version(void)
+ {
+-      fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2005 folkert@vanheusden.com\n");
++      fprintf(stderr, "HTTPing v%s (C) 2003-2005 folkert@vanheusden.com\n", VERSION);
+ #ifndef NO_SSL
+       fprintf(stderr, "SSL support included\n");
+ #endif
+@@ -382,7 +384,7 @@
+       if (useragent)
+               sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
+       else
+-              sprintf(&request[strlen(request)], "User-Agent: HTTPing v" VERSION "\r\n");
++              sprintf(&request[strlen(request)], "User-Agent: HTTPing v%s\r\n", VERSION);
+       if (referer)
+               sprintf(&request[strlen(request)], "Referer: %s\r\n", referer);
+       strcat(request, "\r\n");