[patchteam] - New Package - python2-chardet
authorScott V. Kamp <outbackdingo@gmail.com>
Sat, 13 Mar 2010 02:51:59 +0000 (02:51 +0000)
committerScott V. Kamp <outbackdingo@gmail.com>
Sat, 13 Mar 2010 02:51:59 +0000 (02:51 +0000)
Signed off by alexander@sulfrian.net

SVN-Revision: 20172

lang/python2-chardet/Makefile [new file with mode: 0644]

diff --git a/lang/python2-chardet/Makefile b/lang/python2-chardet/Makefile
new file mode 100644 (file)
index 0000000..ff7b60f
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python2-chardet
+PKG_VERSION:=2.0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://chardet.feedparser.org/download/
+PKG_MD5SUM:=ec771971bab5dd1943a10362ebd2fd4c
+
+PKG_BUILD_DEPENDS:=python
+
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
+
+define Package/python2-chardet
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Universal Encoding Detector
+  URL:=http://chardet.feedparser.org/ http://code.google.com/p/chardet/
+  DEPENDS:=+python
+endef
+
+define Package/python2-chardet/description
+  Character encoding auto-detection in Python.
+endef
+
+define Build/Compile
+       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+endef
+
+define Package/python2-chardet/install
+       $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+       $(CP) \
+           $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+           $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python2-chardet))