[package] openssl: fix annoying build errors when changing upstream versions
authorNicolas Thill <nico@openwrt.org>
Sun, 17 May 2009 00:25:41 +0000 (00:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 17 May 2009 00:25:41 +0000 (00:25 +0000)
SVN-Revision: 15880

package/openssl/Makefile

index 11a9ef2e28c5f65727df66e6e50562cbf3c93dca..55c9a1c62343b0bc119c0478f19c936b5a974da4 100644 (file)
@@ -93,8 +93,9 @@ endef
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
 TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
+       # XXX: OpenSSL "make depend" will look for installed headers before its own,
+       # so remove installed stuff first
+       -$(SUBMAKE) -j1 clean-staging
        $(MAKE) -C $(PKG_BUILD_DIR) \
                MAKEDEPPROG="$(TARGET_CROSS)gcc" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                MAKEDEPPROG="$(TARGET_CROSS)gcc" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \