Added macchanger
authorFlorian Fainelli <florian@openwrt.org>
Sat, 17 Dec 2005 16:49:18 +0000 (16:49 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 17 Dec 2005 16:49:18 +0000 (16:49 +0000)
SVN-Revision: 2712

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/macchanger/Config.in [new file with mode: 0755]
openwrt/package/macchanger/Makefile [new file with mode: 0755]
openwrt/package/macchanger/ipkg/macchanger.control [new file with mode: 0755]

index 9cab42c184aeb1dd109246817f79cbec21d1c8ea..21316ea754cab9b5cd874a737eccb6817e9beb12 100644 (file)
@@ -81,6 +81,7 @@ source "package/l2tpd/Config.in"
 source "package/l2tpns/Config.in"
 source "package/lighttpd/Config.in"
 source "package/linux-atm/Config.in"
+source "package/macchanger/Config.in"
 source "package/maradns/Config.in"
 source "package/mini_httpd/Config.in"
 source "package/mini_sendmail/Config.in"
index 7c8e525db810f78bcc4885a7bc85b4d8e144726e..548f002bff25bf494155bee6b14f5a9520e94aec 100644 (file)
@@ -110,6 +110,7 @@ package-$(BR2_PACKAGE_LIBXSLT) += libxslt
 package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
 package-$(BR2_PACKAGE_LINUX_ATM) += linux-atm
 package-$(BR2_COMPILE_LUA) += lua
+package-$(BR2_PACKAGE_MACCHANGER) += macchanger
 package-$(BR2_PACKAGE_MADPLAY) += madplay
 package-$(BR2_PACKAGE_MADWIFI_TOOLS) += madwifi-tools
 package-$(BR2_PACKAGE_MARADNS) += maradns
diff --git a/openwrt/package/macchanger/Config.in b/openwrt/package/macchanger/Config.in
new file mode 100755 (executable)
index 0000000..a975e4a
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_MACCHANGER
+        tristate "macchanger........................ utility for viewing/manipulating the MAC address"
+       default m if CONFIG_DEVEL
+       help
+               This is a GNU/Linux utility for viewing/manipulating the MAC address
+               of network interfaces.
+               
+               http://www.gnu.org/software/macchanger
diff --git a/openwrt/package/macchanger/Makefile b/openwrt/package/macchanger/Makefile
new file mode 100755 (executable)
index 0000000..2081c92
--- /dev/null
@@ -0,0 +1,50 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=macchanger
+PKG_VERSION:=1.5.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=79b7cdaeca3d8ebafa764c4b0dd03ab7
+PKG_SOURCE_URL:=@gnu/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MACCHANGER,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+                $(TARGET_CONFIGURE_OPTS) \
+                CFLAGS="$(TARGET_CFLAGS)" \
+                ./configure \
+                --target=$(GNU_TARGET_NAME) \
+                --host=$(GNU_TARGET_NAME) \
+                --build=$(GNU_HOST_NAME) \
+                --prefix=/usr \
+                --exec-prefix=/usr \
+                --bindir=/usr/bin \
+                --sbindir=/usr/sbin \
+                --libexecdir=/usr/lib \
+                --sysconfdir=/etc \
+                --datadir=/usr/share \
+                --localstatedir=/var \
+                --mandir=/usr/man \
+                               --mandir=/usr/man \
+                --infodir=/usr/info \
+                --program-prefix="" \
+                               --with-gnu-ld \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+       touch $@
+
+$(IPKG_MACCHANGER):
+       mkdir -p $(IDIR_MACCHANGER)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_MACCHANGER)/
+       $(RSTRIP) $(IDIR_MACCHANGER)
+       $(IPKG_BUILD) $(IDIR_MACCHANGER) $(PACKAGE_DIR)
diff --git a/openwrt/package/macchanger/ipkg/macchanger.control b/openwrt/package/macchanger/ipkg/macchanger.control
new file mode 100755 (executable)
index 0000000..9149cc3
--- /dev/null
@@ -0,0 +1,6 @@
+Package: macchanger
+Section: sys
+Architecture: mipsel
+Priority: optional
+Description: This is a GNU/Linux utility for viewing/manipulating the MAC address
+of network interfaces.