kernel: Allow talitos crypto hw module selection
authorGabor Juhos <juhosg@openwrt.org>
Sat, 6 Apr 2013 12:41:06 +0000 (12:41 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 6 Apr 2013 12:41:06 +0000 (12:41 +0000)
Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 36224

package/kernel/modules/crypto.mk

index 6a3b5a6bae3ed772dd5c5e75636a11c44fc6c454..be76f53251207d2a86a93ea83cb013e0d868d013 100644 (file)
@@ -119,6 +119,20 @@ define KernelPackage/crypto-iv
 endef
 $(eval $(call KernelPackage,crypto-iv))
 
+define KernelPackage/crypto-hw-talitos
+  TITLE:=Freescale integrated security engine (SEC) driver
+  DEPENDS:=+kmod-crypto-aes
+  KCONFIG:= \
+       CONFIG_CRYPTO_DEV_TALITOS
+  FILES:= \
+       $(LINUX_DIR)/drivers/crypto/talitos.ko
+  AUTOLOAD:=$(call AutoLoad,09,talitos)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-hw-talitos))
+
+
 define KernelPackage/crypto-hw-padlock
   TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
   DEPENDS:=+kmod-crypto-aes