gnupg:
authorOliver Ertl <oliver@ertl-net.net>
Fri, 7 Sep 2007 17:01:33 +0000 (17:01 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Fri, 7 Sep 2007 17:01:33 +0000 (17:01 +0000)
 * Update 1.4.2.1 > 1.4.7
 * Cleanup Makefile
 * Don't build po and docs

SVN-Revision: 8671

utils/gnupg/Makefile
utils/gnupg/patches/001-no_po_and_docs.patch [new file with mode: 0644]

index dd81afb94396e639f7e8bde81b3dc59b4904cdac..a49a0616104b71132b3c5b1a4be972c4a8b8381c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,50 +9,49 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnupg
-PKG_VERSION:=1.4.2.1
+PKG_VERSION:=1.4.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/gnupg \
        ftp://ftp.gnupg.org/gcrypt/gnupg
-PKG_MD5SUM:=2d59ed50d92f69994dbfbe00fe1612e4
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=b06a141cca5cd1a55bbdd25ab833303c
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/gnupg
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=GNU Privacy Guard
-  DESCRIPTION:=\
-       GPG is an encryption program.
+  DEPENDS:=+zlib +libncurses +libreadline
+  TITLE:=GNU privacy guard - a free PGP replacement
   URL:=http://www.gnupg.org/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-rpath \
-               --disable-asm \
-               --disable-gnupg-iconv \
-               --disable-card-support \
-               --disable-agent-support \
-               --disable-bzip2 \
-               --disable-exec \
-               --disable-ldap \
-               --disable-hkp \
-               --disable-finger \
-               --disable-ftp \
-               --disable-dns-srv \
-               --enable-fake-curl \
-               --disable-regex \
-       )
+define Package/gnupg/description
+ GnuPG is GNU's tool for secure communication and data storage.
+ It can be used to encrypt data and to create digital signatures.
+ It includes an advanced key management facility and is compliant
+ with the proposed OpenPGP Internet standard as described in RFC2440.
+ GnuPG does not use any patented algorithms so it cannot be compatible
+ with PGP2 because it uses IDEA (which is patented worldwide). 
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-endef
+CONFIGURE_ARGS += \
+       --disable-rpath \
+       --disable-asm \
+       --disable-gnupg-iconv \
+       --disable-card-support \
+       --disable-agent-support \
+       --disable-bzip2 \
+       --disable-exec \
+       --disable-ldap \
+       --disable-hkp \
+       --disable-finger \
+       --disable-ftp \
+       --disable-dns-srv \
+       --enable-fake-curl \
+       --disable-regex \
 
 define Package/gnupg/install
        $(INSTALL_DIR) $(1)/usr/bin
diff --git a/utils/gnupg/patches/001-no_po_and_docs.patch b/utils/gnupg/patches/001-no_po_and_docs.patch
new file mode 100644 (file)
index 0000000..e649499
--- /dev/null
@@ -0,0 +1,13 @@
+Index: gnupg-1.4.7/Makefile.in
+===================================================================
+--- gnupg-1.4.7.orig/Makefile.in       2007-09-07 18:53:42.000000000 +0200
++++ gnupg-1.4.7/Makefile.in    2007-09-07 18:53:42.000000000 +0200
+@@ -311,7 +311,7 @@
+ AUTOMAKE_OPTIONS = dist-bzip2 filename-length-max=99
+ @CROSS_COMPILING_FALSE@checks = checks
+ @CROSS_COMPILING_TRUE@checks = 
+-SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver po doc ${checks}
++SUBDIRS = m4 intl zlib util mpi cipher tools g10 keyserver ${checks}
+ EXTRA_DIST = scripts/config.rpath  PROJECTS BUGS config.h.in autogen.sh
+ DISTCLEANFILES = 
+ all: config.h