cleanup ntfs-3g makefile (remove kernel.mk include, unused configure options...)
authorNicolas Thill <nico@openwrt.org>
Wed, 28 Mar 2007 00:29:17 +0000 (00:29 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 28 Mar 2007 00:29:17 +0000 (00:29 +0000)
SVN-Revision: 6734

package/ntfs-3g/Makefile

index 5c07adaa7c3463063e7cccf455329b3784a3570f..686c0e3c9541b2bd07aaa28bde13deef25b0b9cc 100644 (file)
@@ -7,7 +7,6 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ntfs-3g
 PKG_VERSION:=1.0
 
 PKG_NAME:=ntfs-3g
 PKG_VERSION:=1.0
@@ -31,51 +30,9 @@ define Package/ntfs-3g
   URL:=http://www.ntfs-3g.org
 endef
 
   URL:=http://www.ntfs-3g.org
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               touch configure.in ; \
-               touch aclocal.m4 ; \
-               touch Makefile.in ; \
-               touch include/config.h.in ; \
-               touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --enable-kernel-module \
-                       --enable-lib \
-                       --enable-util \
-                       --disable-example \
-                       --disable-auto-modprobe \
-                       --with-kernel="$(LINUX_DIR)" \
-                       --disable-mtab \
-       );
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \