swconfig: fix backward compatibility
authorGabor Juhos <juhosg@openwrt.org>
Thu, 28 Jul 2011 19:54:11 +0000 (19:54 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 28 Jul 2011 19:54:11 +0000 (19:54 +0000)
swconfig fails to load uci configuration after the generic switch
identifier changes.

root@OpenWrt:/# uci show network | grep switch
network.@switch[0]=switch
network.@switch[0].name=eth0
network.@switch[0].reset=1
network.@switch[0].enable_vlan=1
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device=eth0
network.@switch_vlan[0].vlan=1
network.@switch_vlan[0].ports=0t 2 3 4 5
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device=eth0
network.@switch_vlan[1].vlan=2
network.@switch_vlan[1].ports=0t 1
root@OpenWrt:/# swconfig dev eth0 load /etc/config/network
Failed to apply configuration for switch 'switch0'
root@OpenWrt:/# swconfig dev switch0 load /etc/config/network
Failed to apply configuration for switch 'switch0'

SVN-Revision: 27820

package/swconfig/Makefile
package/swconfig/src/uci.c

index 58ae75f46633edb3a31bf5c29c129cbe188a0e68..91939bb73f4c33cef83c924b3d591732507f5542 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=swconfig
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
index ce544c3d58b76b4429bcfb164f0deacf705f08b3..1de689ce6e3e303641a36a273064ccf5257044be 100644 (file)
@@ -53,6 +53,12 @@ struct swlib_setting early_settings[] = {
 static struct swlib_setting *settings;
 static struct swlib_setting **head;
 
+static bool swlib_match_name(struct switch_dev *dev, const char *name)
+{
+       return (strcmp(name, dev->dev_name) == 0 ||
+               strcmp(name, dev->alias) == 0);
+}
+
 static int
 swlib_map_settings(struct switch_dev *dev, int type, int port_vlan, struct uci_section *s)
 {
@@ -131,13 +137,13 @@ int swlib_apply_from_uci(struct switch_dev *dev, struct uci_package *p)
                        if (o->type != UCI_TYPE_STRING)
                                continue;
 
-                       if (!strcmp(o->v.string, dev->dev_name))
+                       if (swlib_match_name(dev, o->v.string))
                                goto found;
 
                        break;
                }
 
-               if (strcmp(e->name, dev->dev_name) != 0)
+               if (!swlib_match_name(dev, e->name))
                        continue;
 
                goto found;
@@ -171,7 +177,7 @@ found:
 
                                if (!strcmp(os->name, "device")) {
                                        devn = o->v.string;
-                                       if (strcmp(devn, dev->dev_name) != 0)
+                                       if (!swlib_match_name(dev, devn))
                                                devn = NULL;
                                } else if (!strcmp(os->name, "port")) {
                                        port = o->v.string;
@@ -196,7 +202,7 @@ found:
 
                                if (!strcmp(os->name, "device")) {
                                        devn = o->v.string;
-                                       if (strcmp(devn, dev->dev_name) != 0)
+                                       if (!swlib_match_name(dev, devn))
                                                devn = NULL;
                                } else if (!strcmp(os->name, "vlan")) {
                                        vlan = o->v.string;