ar71xx: add ALL0305 board alias
authorGabor Juhos <juhosg@openwrt.org>
Wed, 22 Aug 2012 12:33:22 +0000 (12:33 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 22 Aug 2012 12:33:22 +0000 (12:33 +0000)
For the pure convenience of having a correctly named
image and system name in /proc/cpuinfo , until we can
do that by having system names in DTS...

Signed-off-by: Daniel Golle <dgolle@allnet.de>
SVN-Revision: 33224

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/files/arch/mips/ath79/mach-eap7660d.c
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch

index 02cfa3551638802ebcde7a37c12eac9d94cda092..406d0b1d1c39f1c0fc480ac32c3a2f945dc73d8c 100755 (executable)
@@ -33,6 +33,9 @@ get_status_led() {
        alfa-nx)
                status_led="alfa:green:led_8"
                ;;
        alfa-nx)
                status_led="alfa:green:led_8"
                ;;
+       all0305)
+               status_led="eap7660d:green:ds4"
+               ;;
        ap136)
                status_led="ap136:green:status"
                ;;
        ap136)
                status_led="ap136:green:status"
                ;;
index ae4b88b7c7967b376907c9bec50d1e3853c8fb34..31d757233869f5ba3a80bc115d3b347dbd009368 100755 (executable)
@@ -130,6 +130,7 @@ wzr-hp-g300nh)
        ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 5t"
        ;;
 
        ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 5t"
        ;;
 
+all0305 |\
 aw-nr580 |\
 bullet-m |\
 eap7660d |\
 aw-nr580 |\
 bullet-m |\
 eap7660d |\
index 23d34a33702cf160fa8016d2b67515536923262c..bb92b961443d3ad6969624b2b27c2d92342520e2 100755 (executable)
@@ -159,6 +159,9 @@ ar71xx_board_detect() {
        *ALL0258N)
                name="all0258n"
                ;;
        *ALL0258N)
                name="all0258n"
                ;;
+       *ALL0305)
+               name="all0305"
+               ;;
        *AP113)
                name="ap113"
                ;;
        *AP113)
                name="ap113"
                ;;
index fb5fe7318aad4821b4ca8fc4865810afeba8f927..f1c0164ee3f9be15bcb46dccf1fa0b73a19a1590 100755 (executable)
@@ -189,6 +189,7 @@ platform_check_image() {
        ls-sr71 | \
        pb42 | \
        pb44 | \
        ls-sr71 | \
        pb42 | \
        pb44 | \
+       all0305 | \
        eap7660d | \
        ja76pf | \
        ja76pf2)
        eap7660d | \
        ja76pf | \
        ja76pf2)
@@ -221,6 +222,7 @@ platform_do_upgrade() {
        routerstation | \
        routerstation-pro | \
        ls-sr71 | \
        routerstation | \
        routerstation-pro | \
        ls-sr71 | \
+       all0305 | \
        eap7660d | \
        pb42 | \
        pb44 | \
        eap7660d | \
        pb42 | \
        pb44 | \
index d58eee2bbb293e883cecce7bfb64e0deefbf0fb4..787e6275d634b49ff623040a63d874c379867501 100644 (file)
@@ -176,3 +176,6 @@ static void __init eap7660d_setup(void)
 
 MIPS_MACHINE(ATH79_MACH_EAP7660D, "EAP7660D", "Senao EAP7660D",
             eap7660d_setup);
 
 MIPS_MACHINE(ATH79_MACH_EAP7660D, "EAP7660D", "Senao EAP7660D",
             eap7660d_setup);
+
+MIPS_MACHINE(ATH79_MACH_ALL0305, "ALL0305", "Allnet ALL0305",
+            eap7660d_setup);
index 43bb9d320c3959fcf008bdbabd0559a24e0f9a61..18f78897df4877c965eb9e6e1a5bc47d315a26f1 100644 (file)
@@ -661,6 +661,11 @@ define Image/Build/Profile/ALL0258N
        $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,all0258n,$(all0258n_cmdline),$(all0258n_mtdlayout),1048576,5373952,KRuImage)
 endef
 
        $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,all0258n,$(all0258n_cmdline),$(all0258n_mtdlayout),1048576,5373952,KRuImage)
 endef
 
+all0305_cmdline=board=ALL0305 console=ttyS0,115200
+define Image/Build/Profile/ALL0305
+       $(call Image/Build/Template/$(fs_128k)/$(1),PB4X,all0305,$(all0305_cmdline))
+endef
+
 ap113_mtd_layout=64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
 ap113_cmdline=board=AP113 console=ttyS0,115200
 define Image/Build/Profile/AP113
 ap113_mtd_layout=64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
 ap113_cmdline=board=AP113 console=ttyS0,115200
 define Image/Build/Profile/AP113
@@ -1083,6 +1088,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/ALFAAP96,$(1))
        $(call Image/Build/Profile/ALFANX,$(1))
        $(call Image/Build/Profile/ALL0258N,$(1))
        $(call Image/Build/Profile/ALFAAP96,$(1))
        $(call Image/Build/Profile/ALFANX,$(1))
        $(call Image/Build/Profile/ALL0258N,$(1))
+       $(call Image/Build/Profile/ALL0305,$(1))
        $(call Image/Build/Profile/AP113,$(1))
        $(call Image/Build/Profile/AP121,$(1))
        $(call Image/Build/Profile/AP121MINI,$(1))
        $(call Image/Build/Profile/AP113,$(1))
        $(call Image/Build/Profile/AP121,$(1))
        $(call Image/Build/Profile/AP121MINI,$(1))
index 73db5e44df50fd818ea9fff89ef5fb4019fa972e..34965dcda8537deaeb9370dea3b428ed56361c8e 100644 (file)
@@ -1,12 +1,13 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -16,18 +16,93 @@
+@@ -16,18 +16,94 @@
  
  enum ath79_mach_type {
        ATH79_MACH_GENERIC = 0,
 +      ATH79_MACH_ALFA_AP96,           /* ALFA Network AP96 board */
 +      ATH79_MACH_ALFA_NX,             /* ALFA Network N2/N5 board */
 +      ATH79_MACH_ALL0258N,            /* Allnet ALL0258N */
  
  enum ath79_mach_type {
        ATH79_MACH_GENERIC = 0,
 +      ATH79_MACH_ALFA_AP96,           /* ALFA Network AP96 board */
 +      ATH79_MACH_ALFA_NX,             /* ALFA Network N2/N5 board */
 +      ATH79_MACH_ALL0258N,            /* Allnet ALL0258N */
++      ATH79_MACH_ALL0305,             /* Allnet ALL0305 */
 +      ATH79_MACH_AP113,               /* Atheros AP113 reference board */
        ATH79_MACH_AP121,               /* Atheros AP121 reference board */
        ATH79_MACH_AP121_MINI,          /* Atheros AP121-MINI reference board */
 +      ATH79_MACH_AP113,               /* Atheros AP113 reference board */
        ATH79_MACH_AP121,               /* Atheros AP121 reference board */
        ATH79_MACH_AP121_MINI,          /* Atheros AP121-MINI reference board */