[kernel] update targets to 2.6.30.1, update patches
authorFlorian Fainelli <florian@openwrt.org>
Sun, 5 Jul 2009 14:39:13 +0000 (14:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 5 Jul 2009 14:39:13 +0000 (14:39 +0000)
SVN-Revision: 16697

15 files changed:
include/kernel-version.mk
target/linux/avr32/Makefile
target/linux/cobalt/Makefile
target/linux/etrax/Makefile
target/linux/gemini/Makefile
target/linux/generic-2.6/patches-2.6.30/025-mips_disable_fpu.patch
target/linux/generic-2.6/patches-2.6.30/801-usb_serial_endpoint_size.patch
target/linux/goldfish/Makefile
target/linux/kirkwood/Makefile
target/linux/kirkwood/patches/002-mvsdio_delay.patch
target/linux/octeon/Makefile
target/linux/octeon/patches/105-nb5_fixup.patch
target/linux/rb532/Makefile
target/linux/sibyte/Makefile
target/linux/sibyte/patches/002-sibyte_remove_standalone_support.patch

index f502ab34653584bbfda9afa91c0d8583d3ad32de..ab8c2d41ff74e0dcdcc01b6a784b1d6e21a95856 100644 (file)
@@ -28,8 +28,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.29.2)
   LINUX_KERNEL_MD5SUM:=a6839571a9e70baf821d2fb752f9c4c6
 endif
 ifeq ($(LINUX_VERSION),2.6.29.2)
   LINUX_KERNEL_MD5SUM:=a6839571a9e70baf821d2fb752f9c4c6
 endif
-ifeq ($(LINUX_VERSION),2.6.30)
-  LINUX_KERNEL_MD5SUM:=7a80058a6382e5108cdb5554d1609615
+ifeq ($(LINUX_VERSION),2.6.30.1)
+  LINUX_KERNEL_MD5SUM:=7da2e2e31f1c00f2673d2dc50de76b33
 endif
 
 # disable the md5sum check for unknown kernel versions
 endif
 
 # disable the md5sum check for unknown kernel versions
index 8e23fe96f6aae31149c8d914d571411c0c437706..26bed1627dc6e413d63e71b9b515cdd3c37ca0a7 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index ece8eb9550cfbe1fa8dd4dc2ae14d24c7edb2748..0569e9ab2d11bddcc8a8e43b8609f99d27d6c446 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
-FEATURES:=tgz pci
+FEATURES:=tgz pci ext2
 
 
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index ec81d9f75497abcb1e8a3e7db8d190892e19f538..bb8591bf3db0c03058fe4cb37a97181f53f7e65a 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index bcc0a4a2b9a3c1cc4628366f9adbe22e9a4fc284..bc418b4f1bebf2395e771b9bacf1ad9b2e704a89 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index e71bf48f2103b03b11699765caa8d34948aa7248..ffd0af5f19585bc4a8eea1fd95fe5f6b7e5ce378 100644 (file)
@@ -6,11 +6,9 @@ precious blocks on an embedded system.
 
 Signed-off-by: Florian Fainelli <florian@openwrt.org>
 --
 
 Signed-off-by: Florian Fainelli <florian@openwrt.org>
 --
-diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
-index 65d3b19..a467ee5 100644
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -811,6 +811,17 @@ config I8259
+@@ -791,6 +791,17 @@ config I8259
  config MIPS_BONITO64
        bool
  
  config MIPS_BONITO64
        bool
  
@@ -28,8 +26,6 @@ index 65d3b19..a467ee5 100644
  config MIPS_MSC
        bool
  
  config MIPS_MSC
        bool
  
-diff --git a/arch/mips/math-emu/Makefile b/arch/mips/math-emu/Makefile
-index d547efd..7fdef24 100644
 --- a/arch/mips/math-emu/Makefile
 +++ b/arch/mips/math-emu/Makefile
 @@ -2,12 +2,14 @@
 --- a/arch/mips/math-emu/Makefile
 +++ b/arch/mips/math-emu/Makefile
 @@ -2,12 +2,14 @@
@@ -49,8 +45,6 @@ index d547efd..7fdef24 100644
 +         dp_sqrt.o sp_sqrt.o
  
  EXTRA_CFLAGS += -Werror
 +         dp_sqrt.o sp_sqrt.o
  
  EXTRA_CFLAGS += -Werror
-diff --git a/arch/mips/math-emu/cp1emu.c b/arch/mips/math-emu/cp1emu.c
-index 890f779..9f4c767 100644
 --- a/arch/mips/math-emu/cp1emu.c
 +++ b/arch/mips/math-emu/cp1emu.c
 @@ -56,6 +56,12 @@
 --- a/arch/mips/math-emu/cp1emu.c
 +++ b/arch/mips/math-emu/cp1emu.c
 @@ -56,6 +56,12 @@
@@ -77,7 +71,7 @@ index 890f779..9f4c767 100644
  /* Control registers */
  
  #define FPCREG_RID    0       /* $0  = revision id */
  /* Control registers */
  
  #define FPCREG_RID    0       /* $0  = revision id */
-@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_regs *xcp, struct mips_fpu_struct *ctx,
+@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_r
  
        return sig;
  }
  
        return sig;
  }
@@ -91,11 +85,9 @@ index 890f779..9f4c767 100644
  
  #ifdef CONFIG_DEBUG_FS
  extern struct dentry *mips_debugfs_dir;
  
  #ifdef CONFIG_DEBUG_FS
  extern struct dentry *mips_debugfs_dir;
-diff --git a/arch/mips/math-emu/dsemul.c b/arch/mips/math-emu/dsemul.c
-index df7b9d9..9b42bfd 100644
 --- a/arch/mips/math-emu/dsemul.c
 +++ b/arch/mips/math-emu/dsemul.c
 --- a/arch/mips/math-emu/dsemul.c
 +++ b/arch/mips/math-emu/dsemul.c
-@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mips_instruction ir, unsigned long cpc)
+@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mi
        return SIGILL;          /* force out of emulation loop */
  }
  
        return SIGILL;          /* force out of emulation loop */
  }
  
@@ -113,8 +105,6 @@ index df7b9d9..9b42bfd 100644
 +      return 0;
 +}
 +#endif /* CONFIG_MIPS_FPU_EMU */
 +      return 0;
 +}
 +#endif /* CONFIG_MIPS_FPU_EMU */
-diff --git a/arch/mips/math-emu/kernel_linkage.c b/arch/mips/math-emu/kernel_linkage.c
-index 52e6c58..211a399 100644
 --- a/arch/mips/math-emu/kernel_linkage.c
 +++ b/arch/mips/math-emu/kernel_linkage.c
 @@ -29,6 +29,7 @@
 --- a/arch/mips/math-emu/kernel_linkage.c
 +++ b/arch/mips/math-emu/kernel_linkage.c
 @@ -29,6 +29,7 @@
@@ -125,7 +115,7 @@ index 52e6c58..211a399 100644
  void fpu_emulator_init_fpu(void)
  {
        static int first = 1;
  void fpu_emulator_init_fpu(void)
  {
        static int first = 1;
-@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
+@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struc
  
        return err;
  }
  
        return err;
  }
index 01fa4310b270c0ff2c795d27e20f56648e1bddb8..8eaead929218c6a9238f0d264d727991a9505767 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -857,7 +858,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -864,7 +865,7 @@ int usb_serial_probe(struct usb_interfac
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1312,3 +1313,5 @@ MODULE_LICENSE("GPL");
+@@ -1309,3 +1310,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 08fdb6b579c7b5a411e652439f531130f7dc73d2..78a936596e10c050475334a0b6c6267b839ab044 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Goldfish (Android Emulator)
 FEATURES:=
 CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
 
 FEATURES:=
 CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 DEVICE_TYPE=phone
 
 
 DEVICE_TYPE=phone
 
index 48c173ab724ca2ef7b22516581701ee6ff135081..e6bbef259b4fc609ba55c19f5e5eccaeb1592a79 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
 FEATURES:=tgz usb
 
 BOARDNAME:=Marvell Kirkwood
 FEATURES:=tgz usb
 
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index ee730306aa8263467921bcddf5e2bbab38d64bcd..3f7c56e0328cb6de2db99694a40039d1bf9bb033 100644 (file)
        err = mmc_sd_switch(card, 1, 0, 1, status);
        if (err)
                goto out;
        err = mmc_sd_switch(card, 1, 0, 1, status);
        if (err)
                goto out;
---- a/drivers/mmc/host/mvsdio.c
-+++ b/drivers/mmc/host/mvsdio.c
-@@ -620,9 +620,11 @@ static void mvsd_set_ios(struct mmc_host
-       if (ios->bus_width == MMC_BUS_WIDTH_4)
-               ctrl_reg |= MVSD_HOST_CTRL_DATA_WIDTH_4_BITS;
-+#if 0
-       if (ios->timing == MMC_TIMING_MMC_HS ||
-           ios->timing == MMC_TIMING_SD_HS)
-               ctrl_reg |= MVSD_HOST_CTRL_HI_SPEED_EN;
-+#endif
-       host->ctrl = ctrl_reg;
-       mvsd_write(MVSD_HOST_CTRL, ctrl_reg);
 --- a/drivers/mmc/core/core.c
 +++ b/drivers/mmc/core/core.c
 @@ -286,9 +286,9 @@ void mmc_set_data_timeout(struct mmc_dat
 --- a/drivers/mmc/core/core.c
 +++ b/drivers/mmc/core/core.c
 @@ -286,9 +286,9 @@ void mmc_set_data_timeout(struct mmc_dat
index 96a322667e71716efea4be7d524fcc48c9c7ac86..4c43148e6cf2dc3fd8a4da6e1b7c50333b8bc101 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Octeon
 FEATURES:=squashfs jffs2 pci
 CFLAGS:=-Os -pipe -funit-at-a-time
 
 FEATURES:=squashfs jffs2 pci
 CFLAGS:=-Os -pipe -funit-at-a-time
 
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c28adf32f11ee39df64e5a12e12bcf1b15468e71..2165eb0a1bb855e805bd48f72fa144b897ac1fba 100644 (file)
@@ -9,7 +9,7 @@
        default:
                return "";
        }
        default:
                return "";
        }
---- a/drviers/staging/octeon/cvmx-helper-board.c
+--- a/drivers/staging/octeon/cvmx-helper-board.c
 +++ b/drivers/staging/octeon/cvmx-helper-board.c
 @@ -699,6 +699,7 @@ cvmx_helper_board_usb_clock_types_t __cv
  {
 +++ b/drivers/staging/octeon/cvmx-helper-board.c
 @@ -699,6 +699,7 @@ cvmx_helper_board_usb_clock_types_t __cv
  {
index 638aa2e952cc9453c85115ba2f806feaf926b1c3..175ed4eecf993313a921df51032ad4b1e65cac5c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
index 018539da3adaa8dac648eb0b820ba7227c122747..934b99e19f913014b4372642af65ae00377aa78a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=fpu
 CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
 FEATURES:=fpu
 CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 
-LINUX_VERSION:=2.6.30
+LINUX_VERSION:=2.6.30.1
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index e9d63113fddf6a409bf1e0963fed55ae0c1d0803..2c46ccf66d599e34f9a2cb9d6d0884db67a04eb0 100644 (file)
@@ -103,7 +103,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 -lib-$(CONFIG_SIBYTE_CFE_CONSOLE)      += console.o
 --- a/arch/mips/sibyte/cfe/setup.c
 +++ /dev/null
 -lib-$(CONFIG_SIBYTE_CFE_CONSOLE)      += console.o
 --- a/arch/mips/sibyte/cfe/setup.c
 +++ /dev/null
-@@ -1,350 +0,0 @@
+@@ -1,344 +0,0 @@
 -/*
 - * Copyright (C) 2000, 2001, 2002, 2003 Broadcom Corporation
 - *
 -/*
 - * Copyright (C) 2000, 2001, 2002, 2003 Broadcom Corporation
 - *
@@ -394,13 +394,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 -       */
 -      cfe_cons_handle = cfe_getstdhandle(CFE_STDHANDLE_CONSOLE);
 -      if (cfe_getenv("LINUX_CMDLINE", arcs_cmdline, CL_SIZE) < 0) {
 -       */
 -      cfe_cons_handle = cfe_getstdhandle(CFE_STDHANDLE_CONSOLE);
 -      if (cfe_getenv("LINUX_CMDLINE", arcs_cmdline, CL_SIZE) < 0) {
--              if (argc < 0) {
--                      /*
--                       * It's OK for direct boot to not provide a
--                       *  command line
--                       */
--                      strcpy(arcs_cmdline, "root=/dev/ram0 ");
--              } else {
+-              if (argc >= 0) {
 -                      /* The loader should have set the command line */
 -                      /* too early for panic to do any good */
 -                      printk("LINUX_CMDLINE not defined in cfe.");
 -                      /* The loader should have set the command line */
 -                      /* too early for panic to do any good */
 -                      printk("LINUX_CMDLINE not defined in cfe.");