[packages] add "ntfsprogs", utilities to manage ntfs volumes from within OpenWrt...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Jun 2010 22:26:33 +0000 (22:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Jun 2010 22:26:33 +0000 (22:26 +0000)
SVN-Revision: 21866

utils/ntfsprogs/Makefile [new file with mode: 0644]

diff --git a/utils/ntfsprogs/Makefile b/utils/ntfsprogs/Makefile
new file mode 100644 (file)
index 0000000..a1d3aed
--- /dev/null
@@ -0,0 +1,65 @@
+#
+# Copyright (C) 2010 Gianluigi Tiesi <sherpya@netfarm.it>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ntfsprogs
+PKG_VERSION:=2.0.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/linux-ntfs
+PKG_MD5SUM:=2c402b647bb7aeb1d3f8ce1cc354fd68
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ntfsprogs
+    SECTION:=utils
+    CATEGORY:=Utilities
+    SUBMENU:=Filesystem
+    TITLE:=Linux-NTFS
+    URL:=http://www.linux-ntfs.org/
+    MAINTAINER:=Gianluigi Tiesi <sherpya@netfarm.it>
+endef
+
+define Package/ntfsprogs/description
+ Tools for managing NTFS volumes from Linux
+endef
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-gnome-vfs \
+       --disable-ntfsmount
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               prefix=/usr \
+               DESTDIR=$(PKG_INSTALL_DIR) \
+               all install
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/ntfs $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs.{la,a,so*} $(1)/usr/lib
+endef
+
+define Package/ntfsprogs/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs.so.* $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ntfsfix $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(FIND) $(PKG_INSTALL_DIR)/usr/sbin -type f -exec $(INSTALL_BIN) {} $(1)/usr/sbin \;
+endef
+
+$(eval $(call BuildPackage,ntfsprogs))