kernel: add package for huawei ncm modems
authorJohn Crispin <john@openwrt.org>
Tue, 26 Aug 2014 13:11:56 +0000 (13:11 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 26 Aug 2014 13:11:56 +0000 (13:11 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 42304

package/kernel/linux/modules/usb.mk

index 0b5abdc3351e69afb4d14d57d95f770f2cffcb9a..d47c74623bf349275b5984bfe902c806e134e2fb 100644 (file)
@@ -1215,6 +1215,21 @@ endef
 $(eval $(call KernelPackage,usb-net-cdc-ncm))
 
 
+define KernelPackage/usb-net-huawei-cdc-ncm
+  TITLE:=Support for Huawei CDC NCM connections
+  KCONFIG:=CONFIG_USB_NET_HUAWEI_CDC_NCM
+  FILES:= $(LINUX_DIR)/drivers/$(USBNET_DIR)/huawei_cdc_ncm.ko
+  AUTOLOAD:=$(call AutoProbe,huawei_cdc_ncm)
+  $(call AddDepends/usb-net,+kmod-usb-wdm @(LINUX_3_13||LINUX_3_14))
+endef
+
+define KernelPackage/usb-net-huawei-cdc-ncm/description
+ Kernel support for Huawei CDC NCM connections
+endef
+
+$(eval $(call KernelPackage,usb-net-huawei-cdc-ncm))
+
+
 define KernelPackage/usb-net-sierrawireless
   TITLE:=Support for Sierra Wireless devices
   KCONFIG:=CONFIG_USB_SIERRA_NET