ramips: Added support for ZBT-826 / ZBT-1026
authorJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 09:17:06 +0000 (09:17 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 1 Mar 2016 09:17:06 +0000 (09:17 +0000)
Support for these MT7620-based routers: https://wiki.openwrt.org/toh/zbt/we-826
Based on Oskari’s patches found here: https://dev.openwrt.org/ticket/19996

Signed-off-by: Jamie Stuart <jamie@onebillion.org>
SVN-Revision: 48865

target/linux/ramips/base-files/etc/board.d/01_leds [changed mode: 0755->0644]
target/linux/ramips/base-files/etc/board.d/02_network [changed mode: 0755->0644]
target/linux/ramips/base-files/lib/ramips.sh [changed mode: 0755->0644]
target/linux/ramips/base-files/lib/upgrade/platform.sh [changed mode: 0755->0644]
target/linux/ramips/dts/ZBT-WE826.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7620/profiles/zbt.mk [new file with mode: 0644]

old mode 100755 (executable)
new mode 100644 (file)
index d1b4e15..8fd50fe
@@ -268,6 +268,11 @@ zbt-wa05)
        set_wifi_led "$board:blue:air"
        set_usb_led "$board:blue:usb"
        ;;
+zbt-we826)
+       ucidef_set_led_default "power" "power" "$board:green:power" "1"
+       set_wifi_led "$board:green:wifi"
+       set_usb_led "$board:green:usb"
+       ;;
 zbt-wr8305rt)
        ucidef_set_led_default "power" "power" "$board:green:sys" "1"
        set_usb_led "$board:green:usb"
old mode 100755 (executable)
new mode 100644 (file)
index 0121e51..0a680d0
@@ -209,6 +209,7 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "0:wan" "6@eth0"
                ;;
+       zbt-we826|\
        zbt-wr8305rt)
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "6@eth0"
old mode 100755 (executable)
new mode 100644 (file)
index c6c32fe..c4eb357
@@ -475,6 +475,9 @@ ramips_board_detect() {
        *"ZBT-WA05")
                name="zbt-wa05"
                ;;
+       *"ZBT-WE826")
+               name="zbt-we826"
+               ;;
        *"ZBT-WG2626")
                name="zbt-wg2626"
                ;;
old mode 100755 (executable)
new mode 100644 (file)
index 0cae707..df1eded
@@ -139,6 +139,7 @@ platform_check_image() {
        y1|\
        y1s|\
        zbt-wa05|\
+       zbt-we826|\
        zbt-wg2626|\
        zbt-wr8305rt|\
        zte-q7|\
diff --git a/target/linux/ramips/dts/ZBT-WE826.dts b/target/linux/ramips/dts/ZBT-WE826.dts
new file mode 100644 (file)
index 0000000..22bef99
--- /dev/null
@@ -0,0 +1,124 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "zbtlink,zbt-we826", "ralink,mt7620a-soc";
+       model = "ZBT-WE826";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       palmbus@10000000 {
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       en25q128@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q128";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "wllll";
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       default {
+                               ralink,group = "i2c", "uartf", "wled", "spi refclk", "pa";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               power {
+                       label = "zbt-we826:green:power";
+                       gpios = <&gpio1 14 0>;
+               };
+               usb {
+                       label = "zbt-we826:green:usb";
+                       gpios = <&gpio1 15 0>;
+               };
+               air {
+                       label = "zbt-we826:green:wifi";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       pcie@10140000 {
+               status = "okay";
+       };
+};
\ No newline at end of file
index 307c3f93e6a0b77c3487beab9f6cf3dbefc8d6f9..5d90ced2b5e10bfe6bc6770dfac1307cca8192da 100644 (file)
@@ -976,6 +976,7 @@ Image/Build/Profile/MIWIFI-MINI=$(call BuildFirmware/Default16M/$(1),$(1),miwifi
 Image/Build/Profile/ZTE-Q7=$(call BuildFirmware/Default8M/$(1),$(1),zte-q7,ZTE-Q7)
 Image/Build/Profile/YOUKU-YK1=$(call BuildFirmware/Default16M/$(1),$(1),youku-yk1,YOUKU-YK1)
 Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
+Image/Build/Profile/ZBT-WE826=$(call BuildFirmware/Default16M/$(1),$(1),zbt-we826,ZBT-WE826)
 Image/Build/Profile/ZBT-WR8305RT=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wr8305rt,ZBT-WR8305RT)
 Image/Build/Profile/ArcherC20i=$(call BuildFirmware/Tplink/$(1),$(1),ArcherC20i,ArcherC20i)
 microwrt_mtd_size=16515072
@@ -1018,6 +1019,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/ZTE-Q7,$(1))
        $(call Image/Build/Profile/YOUKU-YK1,$(1))
        $(call Image/Build/Profile/ZBT-WA05,$(1))
+       $(call Image/Build/Profile/ZBT-WE826,$(1))
        $(call Image/Build/Profile/ZBT-WR8305RT,$(1))
        $(call Image/Build/Profile/ArcherC20i,$(1))
        $(call Image/Build/Profile/MicroWRT,$(1))
diff --git a/target/linux/ramips/mt7620/profiles/zbt.mk b/target/linux/ramips/mt7620/profiles/zbt.mk
new file mode 100644 (file)
index 0000000..c33048f
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZBT-WE826
+       NAME:=ZBT-WE826 Device
+       PACKAGES:=\
+               kmod-scsi-core kmod-scsi-generic kmod-mmc kmod-sdhci \
+               block-mount kmod-usb-core kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci \
+               kmod-mt76
+endef
+
+define Profile/ZBT-WE826/Description
+       Support for ZBT WE-826-(B,T) routers
+endef
+$(eval $(call Profile,ZBT-WE826))