fix lcd4linux compile error
authorFelix Fietkau <nbd@openwrt.org>
Sat, 24 Mar 2007 17:16:55 +0000 (17:16 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 24 Mar 2007 17:16:55 +0000 (17:16 +0000)
SVN-Revision: 6672

utils/lcd4linux/Makefile
utils/lcd4linux/patches/120-remove_parport_outb.patch

index 50c48caddbf0d3ebf65b9f4acb0923c55f464ed1..d843b3f4e91ea4172aa95e1c1da5be7402548131 100644 (file)
@@ -36,8 +36,13 @@ endef
 # commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our drivers spec
 PKG_CONFIGURE_DRIVERS:=all,!PNG,!RouterBoard,!X11
 
+CONFIGURE_ARGS += \
+               --without-x \
+               --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
+               --with-plugins=wireless
+
 define Build/Configure
-        (cd $(PKG_BUILD_DIR); touch \
+       (cd $(PKG_BUILD_DIR); touch \
                configure.in \
                aclocal.m4 \
                Makefile.in \
@@ -45,15 +50,7 @@ define Build/Configure
                stamp-h.in \
                config.h.in \
        );
-       $(call Build/Configure/Default, \
-               --without-x \
-               --with-drivers="$(PKG_CONFIGURE_DRIVERS)" \
-               --with-plugins=wireless \
-       )
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
+       $(call Build/Configure/Default)
 endef
 
 define Package/lcd4linux/install
index 37693241a01820dec08214f1ef5c5849cb46d8c1..c47cef278c6dbdd3e4d61f06aeb3d839248102ee 100644 (file)
@@ -13,3 +13,23 @@ diff -urN lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.
  #if !defined(WITH_OUTB) && !defined(WITH_PPDEV)
  #error neither outb() nor ppdev() possible
  #error cannot compile parallel port driver
+diff -ur lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.c
+--- lcd4linux.old/drv_generic_parport.c        2007-03-24 18:14:55.706590000 +0100
++++ lcd4linux.dev/drv_generic_parport.c        2007-03-24 18:15:20.036891568 +0100
+@@ -117,16 +117,6 @@
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+-#ifdef HAVE_SYS_IO_H
+-#include <sys/io.h>
+-#define WITH_OUTB
+-#else
+-#ifdef HAVE_ASM_IO_H
+-#include <asm/io.h>
+-#define WITH_OUTB
+-#endif
+-#endif
+-
+ #if defined (HAVE_LINUX_PARPORT_H) && defined (HAVE_LINUX_PPDEV_H)
+ #define WITH_PPDEV
+ #include <linux/parport.h>