collectd: Work around linkage problems with conflicting librrd versions
authorSteven Barth <cyrus@openwrt.org>
Tue, 23 Sep 2008 16:47:36 +0000 (16:47 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 23 Sep 2008 16:47:36 +0000 (16:47 +0000)
SVN-Revision: 12669

utils/collectd/Makefile

index b88db4e..46fe3b1 100644 (file)
@@ -300,8 +300,8 @@ endif
 
 # exception: mod-rrdtool(1) needs rrdtool
 ifneq ($(CONFIG_PACKAGE_collectd-mod-rrdtool1),)
-       PKG_CONFIGURE_OPTS += --enable-rrdtool
        PKG_CONFIGURE_OPTS += --with-rrdtool=$(wildcard $(BUILD_DIR)/rrdtool-1.0.*)
+       TARGET_LDFLAGS := -L$(wildcard $(BUILD_DIR)/rrdtool-1.0.*)/src/.libs $(TARGET_LDFLAGS)
 endif