disable alsa and openswan on brcm-2.6
authorNicolas Thill <nico@openwrt.org>
Thu, 3 Nov 2005 04:28:44 +0000 (04:28 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 3 Nov 2005 04:28:44 +0000 (04:28 +0000)
SVN-Revision: 2321

openwrt/target/linux/package/Makefile
openwrt/target/linux/package/alsa/Config.in
openwrt/target/linux/package/openswan/Config.in

index db63d4f57722200b9d5d29e68c0a3a73f681d8e1..a3d06b71d15a5f5ff1160435af0ce84b84c4b181 100644 (file)
@@ -2,13 +2,17 @@
 include $(TOPDIR)/rules.mk
 
 ifneq ($(BOARD),ar7)
+ifneq ($(BOARD)-$(KERNEL),brcm-2.6)
 package-$(BR2_PACKAGE_KMOD_ALSA) += alsa
 endif
+endif
 package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
 package-$(BR2_PACKAGE_KMOD_HOSTAP) += hostap
 package-$(BR2_PACKAGE_KMOD_MADWIFI) += madwifi
 package-$(BR2_PACKAGE_KMOD_MINI_FO) += mini_fo
+ifneq ($(BOARD)-$(KERNEL),brcm-2.6)
 package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
+endif
 package-$(BR2_PACKAGE_KMOD_SHFS) += shfs
 package-y += base-files
 
index 62dd21b97aef95f03682ddc70439b68c68995e9b..a68be7a6ad767c75ee52838dcc5b69554871388f 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_KMOD_ALSA
        prompt "kmod-alsa......................... Alsa Sound Drivers"
+       prompt "kmod-alsa......................... Alsa Sound Drivers (FIXME, does not build on 2.6/mipsel)" if BR2_LINUX_2_6_BRCM
        tristate
        default m if CONFIG_DEVEL
        depends BR2_PACKAGE_KMOD_USB_CONTROLLER
index 59a943f8e46b01f16764daaa3c68304aa8dd5c00..52b52ba116f4b45c88744bdae6b095d5ca63eaa1 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_KMOD_OPENSWAN
        prompt "kmod-openswan..................... Openswan kernel module"
+       prompt "kmod-openswan..................... Openswan kernel module (FIXME, does not build on 2.6/mipsel)" if BR2_LINUX_2_6_BRCM
        tristate
        default m if CONFIG_DEVEL
        help