[netfilter] package u32 match and TEE target, patches by Maxim Uvarov
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 08:14:29 +0000 (08:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 May 2011 08:14:29 +0000 (08:14 +0000)
SVN-Revision: 26977

include/netfilter.mk
package/iptables/Makefile
package/kernel/modules/netfilter.mk

index 9da455a07a21051c161c5b5bc64cc5593dcffaac..371571a57e874a664cb95d743c576f96d95d0a3d 100644 (file)
@@ -290,6 +290,14 @@ $(eval $(call nf_add,IPT_TPROXY,CONFIG_NETFILTER_XT_TARGET_TPROXY, $(P_XT)xt_TPR
 # led
 $(eval $(call nf_add,IPT_LED,CONFIG_NETFILTER_XT_TARGET_LED, $(P_XT)xt_LED))
 
+# tee
+
+$(eval $(call nf_add,IPT_TEE,CONFIG_NETFILTER_XT_TARGET_TEE, $(P_XT)xt_TEE))
+
+# u32 
+
+$(eval $(call nf_add,IPT_U32,CONFIG_NETFILTER_XT_MATCH_U32, $(P_XT)xt_u32))
+
 #
 # ebtables
 #
index f0f96f03513536d5baf07b0eb920410d2c72ffa2..61739d35515f65f0c8b6ba7bf4f37189ca5955c5 100644 (file)
@@ -229,6 +229,27 @@ Includes:
 - libxt_TPROXY
 endef
 
+define Package/iptables-mod-tee
+$(call Package/iptables/Module, +kmod-ipt-tee)
+  TITLE:=TEE iptables extensions
+endef
+
+define Package/iptables-mod-tee/description
+TEE iptables extensions.
+Includes:
+- libxt_TEE
+endef
+
+define Package/iptables-mod-u32
+$(call Package/iptables/Module, +kmod-ipt-u32)
+  TITLE:=U32 iptables extensions
+endef
+
+define Package/iptables-mod-u32/description
+U32 iptables extensions.
+Includes:
+- libxt_u32
+endef
 
 define Package/iptables-utils
 $(call Package/iptables/Module, )
@@ -424,6 +445,8 @@ $(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
 $(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
 $(eval $(call BuildPlugin,iptables-mod-hashlimit,$(IPT_HASHLIMIT-m)))
 $(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
+$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
+$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
 $(eval $(call BuildPackage,ip6tables))
 $(eval $(call BuildPackage,ip6tables-utils))
 $(eval $(call BuildPackage,libiptc))
index 61226ee7f09abee1858ab3654395d810cd8c3b4d..64c45558d84299b0948e9d6a9bc68d528d2a138c 100644 (file)
@@ -311,6 +311,41 @@ endef
 
 $(eval $(call KernelPackage,ipt-tproxy))
 
+define KernelPackage/ipt-tee
+  TITLE:=TEE support
+  KCONFIG:= \
+       CONFIG_NETFILTER_XT_TARGET_TEE
+  FILES:= \
+       $(LINUX_DIR)/net/netfilter/xt_TEE.ko \
+       $(foreach mod,$(IPT_TEE-m),$(LINUX_DIR)/net/$(mod).ko)
+  AUTOLOAD:=$(call AutoLoad,45,$(notdir nf_tee $(IPT_TEE-m)))
+  $(call AddDepends/ipt)
+endef
+
+define KernelPackage/ipt-tee/description
+  Kernel modules for TEE
+endef
+
+$(eval $(call KernelPackage,ipt-tee))
+
+
+define KernelPackage/ipt-u32
+  TITLE:=U32 support
+  KCONFIG:= \
+       CONFIG_NETFILTER_XT_MATCH_U32
+  FILES:= \
+       $(LINUX_DIR)/net/netfilter/xt_u32.ko \
+       $(foreach mod,$(IPT_U32-m),$(LINUX_DIR)/net/$(mod).ko)
+  AUTOLOAD:=$(call AutoLoad,45,$(notdir nf_tee $(IPT_U32-m)))
+  $(call AddDepends/ipt)
+endef
+
+define KernelPackage/ipt-u32/description
+  Kernel modules for U32
+endef
+
+$(eval $(call KernelPackage,ipt-u32))
+
 
 define KernelPackage/ipt-iprange
   TITLE:=Module for matching ip ranges