gnutls tweaks:
authorNicolas Thill <nico@openwrt.org>
Tue, 29 Jul 2008 23:31:37 +0000 (23:31 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 29 Jul 2008 23:31:37 +0000 (23:31 +0000)
 - use included libtasn1 library, since gnutls is the only package using it atm
 - use included libcfg library, since it is not packaged yet
 - bump release number

SVN-Revision: 11996

libs/gnutls/Makefile

index f7cb18feac493a001ddff269ecc341456aa1f090..42ee26f8b978f9c7df5f65a5f1357d2e1c8b350d 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gnutls
 PKG_VERSION:=2.4.1
 
 PKG_NAME:=gnutls
 PKG_VERSION:=2.4.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
@@ -70,7 +70,7 @@ endef
 define Package/libgnutls
 $(call Package/gnutls/Default)
  TITLE+= (library)
 define Package/libgnutls
 $(call Package/gnutls/Default)
  TITLE+= (library)
- DEPENDS+= +zlib +libtasn1 +libgcrypt +libgpg-error
+ DEPENDS+= +zlib +libgcrypt +libgpg-error
 endef
 
 define Package/libgnutls/description
 endef
 
 define Package/libgnutls/description
@@ -106,10 +106,11 @@ CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
        --disable-openpgp-authentication \
        --enable-shared \
        --enable-static \
        --disable-openpgp-authentication \
+       --with-included-libcfg \
+       --with-included-libtasn1 \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
        --with-libz-prefix="$(STAGING_DIR)/usr" \
        --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
        --with-libreadline-prefix="$(STAGING_DIR)/usr" \
        --with-libz-prefix="$(STAGING_DIR)/usr" \
-       --with-libtasn1-prefix="$(STAGING_DIR)/usr"
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
 MAKE_ARGS:= \
 
 # XXX: AM_CFLAGS duplicates with CFLAGS
 MAKE_ARGS:= \