maemo-kexec: Rename script to bootmaemo.
authorMichael Büsch <mb@bu3sch.de>
Sat, 16 Oct 2010 21:12:26 +0000 (21:12 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 16 Oct 2010 21:12:26 +0000 (21:12 +0000)
SVN-Revision: 23486

utils/maemo-kexec/Makefile
utils/maemo-kexec/files/sbin/boot-maemo [deleted file]
utils/maemo-kexec/files/sbin/bootmaemo [new file with mode: 0755]

index 05b7f50ddca788daf23a082bf4c74ee6072b7c51..3f31c975556a31551c55b34d7bc785fbfd201f65 100644 (file)
@@ -50,7 +50,7 @@ MAEMO_KRNL_SRC:=$(if $(CONFIG_MAEMO_KEXEC_DOWNLOAD_KERNEL),\
 
 define Package/maemo-kexec/install
        $(INSTALL_DIR) $(1)/boot $(1)/sbin
 
 define Package/maemo-kexec/install
        $(INSTALL_DIR) $(1)/boot $(1)/sbin
-       $(INSTALL_BIN) ./files/sbin/boot-maemo $(1)/sbin/
+       $(INSTALL_BIN) ./files/sbin/bootmaemo $(1)/sbin/
        $(INSTALL_DATA) $(MAEMO_KRNL_SRC) $(1)/boot/maemo.zImage
 endef
 
        $(INSTALL_DATA) $(MAEMO_KRNL_SRC) $(1)/boot/maemo.zImage
 endef
 
diff --git a/utils/maemo-kexec/files/sbin/boot-maemo b/utils/maemo-kexec/files/sbin/boot-maemo
deleted file mode 100755 (executable)
index 6bcd8b1..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-set -e
-/usr/sbin/kexec --load /boot/maemo.zImage --append "root=1f03 rootfstype=jffs2 ro console=tty0 console=ttyMTD5"
-/usr/sbin/kexec --exec
diff --git a/utils/maemo-kexec/files/sbin/bootmaemo b/utils/maemo-kexec/files/sbin/bootmaemo
new file mode 100755 (executable)
index 0000000..498b096
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+set -e
+/bin/sync
+/usr/sbin/kexec --load /boot/maemo.zImage --append "root=1f03 rootfstype=jffs2 ro console=tty0 console=ttyMTD5"
+/usr/sbin/kexec --exec