kernel: update 3.18 to 3.18.1
authorLuka Perkov <luka@openwrt.org>
Sat, 3 Jan 2015 22:59:47 +0000 (22:59 +0000)
committerLuka Perkov <luka@openwrt.org>
Sat, 3 Jan 2015 22:59:47 +0000 (22:59 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 43821

include/kernel-version.mk
target/linux/generic/patches-3.18/405-mtd-old-firmware-uimage-splitter.patch
target/linux/generic/patches-3.18/406-mtd-old-rootfs-squashfs-splitter.patch
target/linux/generic/patches-3.18/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
target/linux/generic/patches-3.18/502-yaffs-3.10-disable-proc-entry.patch
target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-3.18/834-ledtrig-libata.patch

index d4edf9f1eb1d8a93b8325e9ab7f39251fbc25867..1c80a8f68f9508a80dd6b9dd63b857cf54814fcf 100644 (file)
@@ -7,14 +7,14 @@ LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.14 = .27
-LINUX_VERSION-3.18 =
+LINUX_VERSION-3.18 = .1
 
 LINUX_KERNEL_MD5SUM-3.3.8   = f1058f64eed085deb44f10cee8541d50
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_KERNEL_MD5SUM-3.14.27 = 0af2d0702df6ee6d7181e697e0af3481
-LINUX_KERNEL_MD5SUM-3.18    = 9e854df51ca3fef8bfe566dbd7b89241
+LINUX_KERNEL_MD5SUM-3.18.1  = 79c9b73a01e1dce0a4c28828496ef02c
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index a19202a87033ee657b0d7a9def5a07bb34292820..df1d726e86c9b8645d1f2ea3279191ef52ca0a16 100644 (file)
@@ -14,7 +14,7 @@
  endmenu
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -681,6 +681,37 @@ mtd_pad_erasesize(struct mtd_info *mtd, 
+@@ -681,6 +681,37 @@ mtd_pad_erasesize(struct mtd_info *mtd,
        return len;
  }
  
@@ -52,7 +52,7 @@
  #ifdef CONFIG_MTD_SPLIT_FIRMWARE_NAME
  #define SPLIT_FIRMWARE_NAME   CONFIG_MTD_SPLIT_FIRMWARE_NAME
  #else
-@@ -689,7 +720,14 @@ mtd_pad_erasesize(struct mtd_info *mtd, 
+@@ -689,7 +720,14 @@ mtd_pad_erasesize(struct mtd_info *mtd,
  
  static void split_firmware(struct mtd_info *master, struct mtd_part *part)
  {
index d48a6814839e7042fb00ae8fb68c97fefd83d3ee..ca819584321be55a84afd469f6ef0738db4eb815 100644 (file)
@@ -14,7 +14,7 @@
        default y
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -681,6 +681,47 @@ mtd_pad_erasesize(struct mtd_info *mtd, 
+@@ -681,6 +681,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
        return len;
  }
  
index 46881fca2c9419c39540070df53e499715afcedb..4c4720341efe4d6afb516793fe63fde85f43ad9f 100644 (file)
@@ -17,7 +17,7 @@
                                 u64 offset, uint32_t mask_flags)
  {
        part->name = name;
-@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct 
+@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
        part->mask_flags = mask_flags;
  }
  
index 5345678c56498611356ca93681870b7893757837..5b73d3898b42be443494b1a73a85137ed5674b6b 100644 (file)
@@ -8,7 +8,7 @@
  static struct proc_dir_entry *my_proc_entry;
  
  static char *yaffs_dump_dev_part0(char *buf, struct yaffs_dev *dev)
-@@ -3398,6 +3399,7 @@ static int yaffs_proc_write(struct file 
+@@ -3398,6 +3399,7 @@ static int yaffs_proc_write(struct file
                return yaffs_proc_debug_write(file, buf, count, data);
        return yaffs_proc_write_trace_options(file, buf, count, data);
  }
index d870dc5d5f2f7c7b47ad5c9d21b4643b3b61fd63..5acfea6c3aa9df732eb58300225b02fef8133f29 100644 (file)
  }
  #endif
  
-@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2 = skb;
        const struct iphdr *iph;
        struct igmphdr *ih;
-@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct
        case IGMP_HOST_MEMBERSHIP_REPORT:
        case IGMPV2_HOST_MEMBERSHIP_REPORT:
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct
                err = br_ip4_multicast_query(br, port, skb2, vid);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
                break;
        }
  
-@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2;
        const struct ipv6hdr *ip6h;
        u8 icmp6_type;
-@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
            }
        case ICMPV6_MLD2_REPORT:
-@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct
                        goto out;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
index ec61ed9e314df15a4ed6e133052a52868ead2e67..cfe92d9a025d64301ba0d95344205fd9b0708eec 100644 (file)
@@ -22,8 +22,6 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  include/linux/libata.h    |  9 +++++++++
  3 files changed, 66 insertions(+)
 
-diff --git a/drivers/ata/Kconfig b/drivers/ata/Kconfig
-index cd4cccb..7a085ec 100644
 --- a/drivers/ata/Kconfig
 +++ b/drivers/ata/Kconfig
 @@ -46,6 +46,22 @@ config ATA_VERBOSE_ERROR
@@ -49,11 +47,9 @@ index cd4cccb..7a085ec 100644
  config ATA_ACPI
        bool "ATA ACPI Support"
        depends on ACPI && PCI
-diff --git a/drivers/ata/libata-core.c b/drivers/ata/libata-core.c
-index 5c84fb5..eb49e02 100644
 --- a/drivers/ata/libata-core.c
 +++ b/drivers/ata/libata-core.c
-@@ -725,6 +725,19 @@ u64 ata_tf_read_block(struct ata_taskfile *tf, struct ata_device *dev)
+@@ -725,6 +725,19 @@ u64 ata_tf_read_block(struct ata_taskfil
        return block;
  }
  
@@ -73,7 +69,7 @@ index 5c84fb5..eb49e02 100644
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4761,6 +4774,9 @@ static struct ata_queued_cmd *ata_qc_new(struct ata_port *ap)
+@@ -4753,6 +4766,9 @@ static struct ata_queued_cmd *ata_qc_new
                        break;
                }
        }
@@ -83,7 +79,7 @@ index 5c84fb5..eb49e02 100644
  
        return qc;
  }
-@@ -5671,6 +5687,9 @@ struct ata_port *ata_port_alloc(struct ata_host *host)
+@@ -5663,6 +5679,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -93,7 +89,7 @@ index 5c84fb5..eb49e02 100644
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5692,6 +5711,12 @@ static void ata_host_release(struct device *gendev, void *res)
+@@ -5684,6 +5703,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -106,7 +102,7 @@ index 5c84fb5..eb49e02 100644
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6138,7 +6163,23 @@ int ata_host_register(struct ata_host *host, struct scsi_host_template *sht)
+@@ -6130,7 +6155,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -114,11 +110,11 @@ index 5c84fb5..eb49e02 100644
 +      for (i = 0; i < host->n_ports; i++) {
 +              if (unlikely(!host->ports[i]->ledtrig))
 +                      continue;
-+
 +              snprintf(host->ports[i]->ledtrig_name,
 +                      sizeof(host->ports[i]->ledtrig_name), "ata%u",
 +                      host->ports[i]->print_id);
++
 +              host->ports[i]->ledtrig->name = host->ports[i]->ledtrig_name;
 +
 +              if (led_trigger_register(host->ports[i]->ledtrig)) {
@@ -130,8 +126,6 @@ index 5c84fb5..eb49e02 100644
        /* Create associated sysfs transport objects  */
        for (i = 0; i < host->n_ports; i++) {
                rc = ata_tport_add(host->dev,host->ports[i]);
-diff --git a/include/linux/libata.h b/include/linux/libata.h
-index 2d18241..4428e2b 100644
 --- a/include/linux/libata.h
 +++ b/include/linux/libata.h
 @@ -38,6 +38,9 @@
@@ -144,7 +138,7 @@ index 2d18241..4428e2b 100644
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -862,6 +865,12 @@ struct ata_port {
+@@ -861,6 +864,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
@@ -157,6 +151,3 @@ index 2d18241..4428e2b 100644
        /* owned by EH */
        u8                      sector_buf[ATA_SECT_SIZE] ____cacheline_aligned;
  };
--- 
-2.1.3
-