samba: don't overwrite config file
authorJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 13:39:23 +0000 (13:39 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 1 Apr 2015 13:39:23 +0000 (13:39 +0000)
fixes #19087

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 45220

package/network/services/samba36/Makefile

index 70dfb2b16f6ff796a7483def5c27e8e0e2d871f8..a3daf58d559488cab111b6e434db2580830349fe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.25
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/stable
@@ -123,10 +123,14 @@ CONFIGURE_ARGS += \
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
+define Package/samba36-server/conffiles
+/etc/config/samba
+endef
+
 define Package/samba36-server/install
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba
-       $(INSTALL_DIR) $(1)/etc/samba
+       $(INSTALL_CONF) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/lowcase.dat $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/upcase.dat $(1)/etc/samba