[packages] gta1: Properly fix paths in gtk-config
authorLars-Peter Clausen <lars@metafoo.de>
Fri, 19 Feb 2010 04:19:45 +0000 (04:19 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Fri, 19 Feb 2010 04:19:45 +0000 (04:19 +0000)
SVN-Revision: 19730

Xorg/lib/gtk1/Makefile

index 9594248f7b9b7a2bec726e6f7c7abb08f7a38780..6feac6ed8b4c5a3db54ef4257a2631fc4a5da208 100644 (file)
@@ -46,6 +46,9 @@ define Build/InstallDev
        $(INSTALL_DIR) $(2)/bin
        mv $(1)/usr/bin/gtk-config $(2)/bin/
        $(SED) "s,libdirs=-L.*,libdirs=,g" $(2)/bin/gtk-config
        $(INSTALL_DIR) $(2)/bin
        mv $(1)/usr/bin/gtk-config $(2)/bin/
        $(SED) "s,libdirs=-L.*,libdirs=,g" $(2)/bin/gtk-config
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1="$(STAGING_DIR)/usr",g' \
+               $(2)/bin/gtk-config
 endef
 
 $(eval $(call BuildPackage,gtk1))
 endef
 
 $(eval $(call BuildPackage,gtk1))